summaryrefslogtreecommitdiff
path: root/packages/unik-olsrd/unik-olsrd_cvs.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
commitfe938bbed352811a2e176797d9f5295d270564e8 (patch)
treeb482ac8d4bbe1d878d08b41d7f73d95b00459474 /packages/unik-olsrd/unik-olsrd_cvs.bb
parent8c45dce3743063bf4f15c5c17597fbeb15061d5f (diff)
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/14 12:27:14+01:00 (none)!br1 Merge http://oe-devel@oe-devel.bkbits.net/openembedded into null.(none):/data/mtx/oe/openembedded 2004/12/14 12:26:43+01:00 (none)!br1 add mtx-1 i2c support 2004/12/14 11:02:03+01:00 (none)!br1 unik-olsrd 0.4.8 2004/12/14 11:00:53+01:00 (none)!br1 little fixes for bitbake 2004/12/14 10:59:06+01:00 (none)!br1 nylon updates 2004/12/14 03:27:14-06:00 ti.com!kergoth More PACKAGE_ARCH/MACHINE_ARCH updates for the multi-z builds. BKrev: 41bee140kQ_QwKwcIxgyouZUyeqwmA
Diffstat (limited to 'packages/unik-olsrd/unik-olsrd_cvs.bb')
-rw-r--r--packages/unik-olsrd/unik-olsrd_cvs.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/unik-olsrd/unik-olsrd_cvs.bb b/packages/unik-olsrd/unik-olsrd_cvs.bb
index e69de29bb2..122f76cc53 100644
--- a/packages/unik-olsrd/unik-olsrd_cvs.bb
+++ b/packages/unik-olsrd/unik-olsrd_cvs.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "OLSR mesh routing daemon"
+HOMEPAGE = "http://www.olsr.org"
+DESCRIPTION_unik-olsrd-libs = "OLSR mesh routing daemon - optional libraries"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "BSD"
+PV = "cvs${CVSDATE}"
+
+SRC_URI="cvs://anonymous@cvs.sourceforge.net/cvsroot/olsrd;module=olsrd-current \
+ file://unik-olsrd \
+ file://olsrd.conf"
+
+PACKAGES =+ "unik-olsrd-libs"
+FILES_unik-olsrd-libs = "${libdir}"
+
+S = "${WORKDIR}/olsrd-current"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "unik-olsrd"
+INITSCRIPT_PARAMS = "defaults"
+
+do_compile() {
+ touch .depend
+ touch src/cfgparser/.depend
+ oe_runmake OS=linux clean all libs
+}
+
+do_install () {
+ oe_runmake INSTALL_PREFIX=${D} install install_libs
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/unik-olsrd ${D}/${sysconfdir}/init.d
+ install -m 644 ${WORKDIR}/olsrd.conf ${D}/${sysconfdir}
+}
+
+CONFFILES_${PN} = "${sysconfdir}/olsrd.conf"