summaryrefslogtreecommitdiff
path: root/packages/unifdef/unifdef-native_2.6.18+git.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-09-25 21:53:58 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-09-25 21:53:58 +0000
commit2b3c2d418ea9902ac2190fe0f4dba2acbd178fa5 (patch)
tree07a6abd3af348bfe68ca0ba3a10d3b9a23159bbe /packages/unifdef/unifdef-native_2.6.18+git.bb
parent41fa5a8dbe2037292318aeab9d41af4de3688414 (diff)
* add unifdef-native, an utility from 2.6.18-git that's used to generate userland headers
* make linux-libc-headers DEPEND on unifdef-native
Diffstat (limited to 'packages/unifdef/unifdef-native_2.6.18+git.bb')
-rw-r--r--packages/unifdef/unifdef-native_2.6.18+git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/unifdef/unifdef-native_2.6.18+git.bb b/packages/unifdef/unifdef-native_2.6.18+git.bb
new file mode 100644
index 0000000000..f2992ca709
--- /dev/null
+++ b/packages/unifdef/unifdef-native_2.6.18+git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Kernel header preprocessor"
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "file://unifdef.c"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o unifdef ${WORKDIR}/unifdef.c
+}
+
+do_stage() {
+ install -m 0755 unifdef ${STAGING_BINDIR}
+}
+
+do_install() {
+ :
+}
+