summaryrefslogtreecommitdiff
path: root/packages/udev
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-04-04 09:27:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-04 09:27:59 +0000
commit414a70ace8cf06857958fad7f87cfcb63b350072 (patch)
tree71a0005a35f07b5273ebfe337783e692c3262c0a /packages/udev
parent2444331e2870baa9e5bf3978571cc7fc06cd13c7 (diff)
parent6ce3ce8860572954d283d4ec66364875d66a6d9c (diff)
merge of 85a1c1efe7466253130cd2e2a63079154ba54454
and c67d38b84a548cc9efa81f9371658f5c59e87e43
Diffstat (limited to 'packages/udev')
-rw-r--r--packages/udev/files/local.rules17
-rw-r--r--packages/udev/files/udev.rules2
-rw-r--r--packages/udev/udev-084/local.rules28
-rw-r--r--packages/udev/udev-084/udev.rules2
-rw-r--r--packages/udev/udev_084.bb2
5 files changed, 48 insertions, 3 deletions
diff --git a/packages/udev/files/local.rules b/packages/udev/files/local.rules
index 4bcaaa8aba..5f2efbeb0c 100644
--- a/packages/udev/files/local.rules
+++ b/packages/udev/files/local.rules
@@ -1,5 +1,22 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+# For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Media automounting
SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+# Handle network interface setup
SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
diff --git a/packages/udev/files/udev.rules b/packages/udev/files/udev.rules
index 044ababa7f..5c566f6cef 100644
--- a/packages/udev/files/udev.rules
+++ b/packages/udev/files/udev.rules
@@ -28,7 +28,7 @@ BUS=="usb", KERNEL=="ttyUSB*", SYSFS{product}=="Palm Handheld*", \
# usbfs-like devices
SUBSYSTEM=="usb_device", \
- PROGRAM="/bin/sh -c 'X=%k X=$${X#usbdev} B=$${X%%%%.*} D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
+ PROGRAM="/bin/sh -c 'export X=%k; export X=$${X#usbdev}; export B=$${X%%%%.*}; export D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
# serial devices
KERNEL=="capi", NAME="capi20", SYMLINK+="isdn/capi20"
diff --git a/packages/udev/udev-084/local.rules b/packages/udev/udev-084/local.rules
new file mode 100644
index 0000000000..bb8459ba23
--- /dev/null
+++ b/packages/udev/udev-084/local.rules
@@ -0,0 +1,28 @@
+# There are a number of modifiers that are allowed to be used in some
+# of the different fields. They provide the following subsitutions:
+#
+# %n the "kernel number" of the device.
+# For example, 'sda3' has a "kernel number" of '3'
+# %e the smallest number for that name which does not matches an existing node
+# %k the kernel name for the device
+# %M the kernel major number for the device
+# %m the kernel minor number for the device
+# %b the bus id for the device
+# %c the string returned by the PROGRAM
+# %s{filename} the content of a sysfs attribute
+# %% the '%' char itself
+#
+
+# Media automounting
+SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
+SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
+
+# Handle network interface setup
+SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
+SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
+
+# The first rtc device is symlinked to /dev/rtc
+KERNEL="rtc0", SYMLINK="rtc"
+
+# Try and modprobe for drivers for new hardware
+ACTION="add", DEVPATH="/devices/*", MODALIAS=="?*", RUN+="/sbin/modprobe $modalias"
diff --git a/packages/udev/udev-084/udev.rules b/packages/udev/udev-084/udev.rules
index 6308cb0918..7b4152c5bf 100644
--- a/packages/udev/udev-084/udev.rules
+++ b/packages/udev/udev-084/udev.rules
@@ -28,7 +28,7 @@ BUS=="usb", KERNEL=="ttyUSB*", SYSFS{product}=="Palm Handheld*", \
# usbfs-like devices
SUBSYSTEM=="usb_device", \
- PROGRAM="/bin/sh -c 'X=%k X=$${X#usbdev} B=$${X%%%%.*} D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
+ PROGRAM="/bin/sh -c 'export X=%k; export X=$${X#usbdev}; export B=$${X%%%%.*}; export D=$${X#*.}; echo bus/usb/$$B/$$D'", SYMLINK+="%c"
# serial devices
KERNEL=="capi", NAME="capi20", SYMLINK+="isdn/capi20"
diff --git a/packages/udev/udev_084.bb b/packages/udev/udev_084.bb
index 85393315c5..6bafa615d7 100644
--- a/packages/udev/udev_084.bb
+++ b/packages/udev/udev_084.bb
@@ -13,7 +13,7 @@ include udev.inc
INITSCRIPT_PARAMS = "start 03 S . start 55 0 6 ."
-PR = "r1"
+PR = "r3"
FILES_${PN} += "${base_libdir}"
UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"