summaryrefslogtreecommitdiff
path: root/packages/udev/udev_100.bb
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-11-13 19:19:49 +0000
committerMatt Reimer <mattjreimer@gmail.com>2006-11-13 19:19:49 +0000
commitfe6bc5b4cabb5fcf87b8944b4cfbe73bb48ceecf (patch)
treeb647d0f995205700148a392c69cccfe9077c7308 /packages/udev/udev_100.bb
parent2b622239c20657486f9e84842fd392f0a03c4598 (diff)
parentf7171587f09b13c97cc73109cd9eaf7c5aa78e47 (diff)
merge of '440352b74d1975abf361c30e00a2519bd5c8051e'
and '493bfe4db4e2664b2f5a442c4973208d987e2752'
Diffstat (limited to 'packages/udev/udev_100.bb')
-rw-r--r--packages/udev/udev_100.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/packages/udev/udev_100.bb b/packages/udev/udev_100.bb
index 31d49d44d8..183d785627 100644
--- a/packages/udev/udev_100.bb
+++ b/packages/udev/udev_100.bb
@@ -9,7 +9,7 @@ used to detect the type of a file system and read its metadata."
DESCRIPTION_libvolume-id-dev = "libvolume_id development headers, \
needed to link programs with libvolume_id."
-PR = "r2"
+PR = "r3"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -62,3 +62,20 @@ do_install () {
do_install_append_h2200() {
install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
}
+
+pkg_postinst_append() {
+
+ # Add the root partition to mount.blacklist to avoid a bug in the auto-mounter,
+ # causing confusion with fsck on boot
+
+ while read dev mp fs junk
+ do
+ if test "$mp" = "/"
+ then
+ root_partition="$dev"
+ echo "$root_partition" >> /etc/udev/mount.blacklist
+ fi
+ done < /etc/fstab
+
+}
+