summaryrefslogtreecommitdiff
path: root/packages/udev/udev_092.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-06-13 18:25:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-13 18:25:24 +0000
commit36ef5a800d97f16721f418d5be5f529a59f301c3 (patch)
tree3259532f4fcc5fba235eb89aa65344f52ad5a284 /packages/udev/udev_092.bb
parent03829814a583050e32ab8bcac2c0c5b5c04fc288 (diff)
udev: Add 092. Included is a custom rule which adds a symlink to the touchscreen as /dev/input/touchscreen0 if present (this does not work under udev 089 due to bugs). Several udev conf files required cleanups to work with the new udev version.
Diffstat (limited to 'packages/udev/udev_092.bb')
-rw-r--r--packages/udev/udev_092.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
new file mode 100644
index 0000000000..62bc43d48f
--- /dev/null
+++ b/packages/udev/udev_092.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "udev is a daemon which dynamically creates and removes device nodes from \
+/dev/, handles hotplug events and loads drivers at boot time. It replaces \
+the hotplug package and requires a kernel not older than 2.6.12."
+RPROVIDES = "hotplug"
+
+PR = "r3"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
+ file://noasmlinkage.patch;patch=1 \
+ file://flags.patch;patch=1 \
+ file://udevsynthesize.patch;patch=1 \
+ file://udevsynthesize.sh \
+ file://mount.blacklist"
+
+include udev.inc
+
+INITSCRIPT_PARAMS = "start 03 S ."
+
+FILES_${PN} += "${base_libdir}"
+UDEV_EXTRAS = "extras/firmware/ extras/scsi_id/ extras/volume_id/ extras/run_directory/"
+EXTRA_OEMAKE += "libudevdir=/lib/udev"
+
+do_install () {
+ install -d ${D}${usrsbindir} \
+ ${D}${sbindir}
+ oe_runmake 'DESTDIR=${D}' INSTALL=install install
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/udev
+
+ install -d ${D}${sysconfdir}/udev/rules.d/
+
+ install -m 0644 ${WORKDIR}/mount.blacklist ${D}${sysconfdir}/udev/
+ install -m 0644 ${WORKDIR}/local.rules ${D}${sysconfdir}/udev/rules.d/local.rules
+ install -m 0644 ${WORKDIR}/permissions.rules ${D}${sysconfdir}/udev/rules.d/permissions.rules
+ install -m 0644 ${WORKDIR}/udev.rules ${D}${sysconfdir}/udev/rules.d/udev.rules
+ install -m 0644 ${WORKDIR}/links.conf ${D}${sysconfdir}/udev/links.conf
+ if [ "${UDEV_DEVFS_RULES}" = "1" ]; then
+ install -m 0644 ${WORKDIR}/devfs-udev.rules ${D}${sysconfdir}/udev/rules.d/devfs-udev.rules
+ fi
+
+ install -d ${D}${sysconfdir}/udev/scripts/
+
+ install -m 0755 ${WORKDIR}/mount.sh ${D}${sysconfdir}/udev/scripts/mount.sh
+ install -m 0755 ${WORKDIR}/network.sh ${D}${sysconfdir}/udev/scripts
+
+ install -d ${D}${base_libdir}/udev/
+ install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
+ install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
+}