summaryrefslogtreecommitdiff
path: root/packages/udev/udev_092.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-11-07 12:02:31 +0000
committerMatthias Hentges <oe@hentges.net>2006-11-07 12:02:31 +0000
commit3b7d18f95dbaaca9faa1ffcc9a780431e7351902 (patch)
treee1c739a8399ba2e9f9b76ffbace59b2c58b63f79 /packages/udev/udev_092.bb
parentb2b8e8ebef369da9281fea67b2c0c7e57d48f6e4 (diff)
udev: Auto-add the rootfs partition to mount.blacklist via postinst to work around a bug in the auto-mounter * * Untested in .dev! * *
Diffstat (limited to 'packages/udev/udev_092.bb')
-rw-r--r--packages/udev/udev_092.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
index 2de59fb018..3d33938fb1 100644
--- a/packages/udev/udev_092.bb
+++ b/packages/udev/udev_092.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES = "hotplug"
-PR = "r12"
+PR = "r13"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -57,3 +57,20 @@ do_install () {
do_install_append_h2200() {
install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
}
+
+pkg_postinst_append() {
+
+ # Add the root partition to mount.blacklist to avoid a bug in the auto-mounter,
+ # causing confusion with fsck on boot
+
+ while read dev mp fs junk
+ do
+ if test "$mp" = "/"
+ then
+ root_partition="$dev"
+ echo "$root_partition" >> /etc/udev/mount.blacklist
+ fi
+ done < /etc/fstab
+
+}
+