summaryrefslogtreecommitdiff
path: root/packages/udev/udev_063.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-17 23:28:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-17 23:28:41 +0000
commit7192303185d67dbd5a417d95df279cac0a246789 (patch)
tree010f6bc3303ff08dbb46b45e2b90023797109513 /packages/udev/udev_063.bb
parent829db8137bd0e83a8aac4599eb7edc6c0f2fa445 (diff)
udev:
- add master plan for udev >= 059 integration (see FIXME) - add alignment fix (http://sourceforge.net/mailarchive/forum.php?thread_id=7720331&forum_id=3157)
Diffstat (limited to 'packages/udev/udev_063.bb')
-rw-r--r--packages/udev/udev_063.bb26
1 files changed, 18 insertions, 8 deletions
diff --git a/packages/udev/udev_063.bb b/packages/udev/udev_063.bb
index 60340ca175..083a6bf88a 100644
--- a/packages/udev/udev_063.bb
+++ b/packages/udev/udev_063.bb
@@ -1,13 +1,23 @@
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
- file://tmpfs.patch;patch=1 \
- file://noasmlinkage.patch;patch=1 \
- file://flags.patch;patch=1 \
- file://init"
+ file://tmpfs.patch;patch=1 \
+ file://noasmlinkage.patch;patch=1 \
+ file://flags.patch;patch=1 \
+ file://fix-alignment.patch;patch=1 \
+ file://init"
include udev.inc
-PR = "r0"
+PR = "r1"
-#FIXME a) udevd doesn't start with our init script (the init script seems to be pretty oudated)
-#FIXME b) lots of alignment errors when manually starting udevd
-DEFAULT_PREFERENCE = "-1"
+#FIXME UDEV MIGRATION PLAN:
+#FIXME a) udevd is now a netlink daemon and needs to be started by the init script (ours is way too old)
+#FIXME b) sbin/hotplug should no longer be called by the kernel, i.e. echo "" >/proc/sys/kernel/hotplug
+#FIXME done c) until d) happens, udev will emulate hotplugd behaviour (see do_install_append()
+#FIXME d) eventually hotplug should no longer be used at all, all agents shall be converted to udev rules
+
+EXTRA_OEMAKE = "EXTRAS=extras/run_directory/"
+
+do_install_append() {
+ install -m 0755 extras/run_directory/udev_run_hotplugd ${D}${sbindir}/
+ echo RUN+="/sbin/udev_run_hotplugd" >>${D}${sysconfdir}/udev/rules.d/50-udev.rules
+}