summaryrefslogtreecommitdiff
path: root/packages/udev/udev-static-devices.bb
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2009-01-12 14:39:16 +0800
committerJohn Lee <john_lee@openmoko.org>2009-01-12 14:39:16 +0800
commit366bf6043abfbbbfa98168548f42aa9aaf6c28b9 (patch)
treeec24779b5ed382cbd3077595cd54a62fad4741c7 /packages/udev/udev-static-devices.bb
parentb4e78908d6ed0b4a142dabc9e72b1a81b7f3c581 (diff)
parent5c898f6e20d5d27a1cc0747746d35f706fd6dfff (diff)
Merge commit 'origin/john_lee/fastboot-devel' into org.openembedded.dev
Diffstat (limited to 'packages/udev/udev-static-devices.bb')
-rw-r--r--packages/udev/udev-static-devices.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/udev/udev-static-devices.bb b/packages/udev/udev-static-devices.bb
new file mode 100644
index 0000000000..f0aab5a6a2
--- /dev/null
+++ b/packages/udev/udev-static-devices.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Provide per-machine static nodes of /dev"
+RDEPENDS = "udev"
+
+PR = "r0"
+
+SRC_URI = "file://udev_static_devices_tarball"
+
+FILES_${PN} += "${base_libdir}/udev/*"
+
+do_install () {
+ install -d ${D}${base_libdir}/udev/devices
+ if [ -s ${WORKDIR}/udev_static_devices_tarball ]; then
+ install -m 0644 ${WORKDIR}/udev_static_devices_tarball ${D}${base_libdir}/udev/devices.tar.gz
+ fi
+}
+
+pkg_postinst () {
+ ROOT="$D"
+ if [ -f "$ROOT/lib/udev/devices.tar.gz" ]; then
+ tar -C "$ROOT/lib/udev" -zxf "$ROOT/lib/udev/devices.tar.gz" || exit $?
+ fi
+}