summaryrefslogtreecommitdiff
path: root/packages/udev/udev-097/flags.patch
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-08-22 08:48:46 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2006-08-22 08:48:46 +0000
commitc0afd4cb563555e06843c196c8af83ad9df1b394 (patch)
tree35fdfb816c1f3b2507bf08405096dbe4d26a531a /packages/udev/udev-097/flags.patch
parentb1ffd3cf9d1349941d57048aa49845a4a61fa998 (diff)
udev: add 097
- drop support for kernels <2.6.15, udevsynthesize replaced by udevtrigger - split out libvolume_id into its own package - I set PKG_libvolume-id-dev="libvolume-id-dev" because otherwise libvolume-id-dev would be renamed to libvolume-id0, too. - DEFAULT_PREFERENCE="-1", it's not run-time tested yet.
Diffstat (limited to 'packages/udev/udev-097/flags.patch')
-rw-r--r--packages/udev/udev-097/flags.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/udev/udev-097/flags.patch b/packages/udev/udev-097/flags.patch
new file mode 100644
index 0000000000..492a39881c
--- /dev/null
+++ b/packages/udev/udev-097/flags.patch
@@ -0,0 +1,51 @@
+--- udev-089/Makefile.orig 2006-04-08 13:32:53.000000000 +0200
++++ udev-089/Makefile 2006-04-08 13:34:27.000000000 +0200
+@@ -117,28 +117,28 @@
+ AR = $(CROSS_COMPILE)ar
+ RANLIB = $(CROSS_COMPILE)ranlib
+
+-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS += $(WARNINGS)
++override CFLAGS += $(WARNINGS)
+
+ LDFLAGS = -Wl,-warn-common
+
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -DDEBUG
++ override CFLAGS += -DDEBUG
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS += -fprofile-arcs
+ endif
+
+@@ -151,11 +151,11 @@
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+