summaryrefslogtreecommitdiff
path: root/packages/udev/udev-089/flags.patch
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-11 10:37:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-11 10:37:45 +0000
commit4dbac5bc4465261136bca6e3b9b2c35ddab50174 (patch)
treea76bd07fe80dff6f967c3ff5955bd936503cb09d /packages/udev/udev-089/flags.patch
parentfab0d798c878034880b1a072684d1a0526ef7090 (diff)
parent02a7ba97f61e2d7ec73013612472307f0d9a8b34 (diff)
merge of 830a2ca2c9484467078002caaef98f80db84c191
and a5073c2c09ef06e7875d4a30ddfdb0a9b8bd58f3
Diffstat (limited to 'packages/udev/udev-089/flags.patch')
-rw-r--r--packages/udev/udev-089/flags.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/udev/udev-089/flags.patch b/packages/udev/udev-089/flags.patch
new file mode 100644
index 0000000000..492a39881c
--- /dev/null
+++ b/packages/udev/udev-089/flags.patch
@@ -0,0 +1,51 @@
+--- udev-089/Makefile.orig 2006-04-08 13:32:53.000000000 +0200
++++ udev-089/Makefile 2006-04-08 13:34:27.000000000 +0200
+@@ -117,28 +117,28 @@
+ AR = $(CROSS_COMPILE)ar
+ RANLIB = $(CROSS_COMPILE)ranlib
+
+-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS += $(WARNINGS)
++override CFLAGS += $(WARNINGS)
+
+ LDFLAGS = -Wl,-warn-common
+
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -DDEBUG
++ override CFLAGS += -DDEBUG
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS += -fprofile-arcs
+ endif
+
+@@ -151,11 +151,11 @@
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+