summaryrefslogtreecommitdiff
path: root/packages/udev/udev-084/flags.patch
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-02-01 20:46:00 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-01 20:46:00 +0000
commit6d0cbb9292836080fe20feb2e450dd61a4a71019 (patch)
tree9f4a6ce83c058a30b9b70d27c0478e10f09db39f /packages/udev/udev-084/flags.patch
parent1f08c565b557892a5717af0d1283d97e9c4aa61c (diff)
udev: add 084
- Fixes the severe udev initial boot speed issues for hx4700. - DEFAULT_PREFERENCE="-1", please try if it works for you. - Uses udevsynthesize to generate initial hotplug events.
Diffstat (limited to 'packages/udev/udev-084/flags.patch')
-rw-r--r--packages/udev/udev-084/flags.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/udev/udev-084/flags.patch b/packages/udev/udev-084/flags.patch
new file mode 100644
index 0000000000..f144a5f622
--- /dev/null
+++ b/packages/udev/udev-084/flags.patch
@@ -0,0 +1,52 @@
+--- udev-081/Makefile.orig 2006-01-29 12:36:33.000000000 +0100
++++ udev-081/Makefile 2006-01-29 12:36:58.000000000 +0100
+@@ -123,29 +123,29 @@
+ STRIP = $(CROSS)strip
+ STRIPCMD = $(STRIP) -s
+
+-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS += $(WARNINGS)
++override CFLAGS += $(WARNINGS)
+
+ LDFLAGS = -Wl,-warn-common
+
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -DDEBUG
++ override CFLAGS += -DDEBUG
+ STRIPCMD =
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS += -fprofile-arcs
+ endif
+
+@@ -160,11 +160,11 @@
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+