summaryrefslogtreecommitdiff
path: root/packages/udev/udev-065
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-08-15 19:30:15 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-08-15 19:30:15 +0000
commit5f17a1f49a5965bf1667499b081544894d36cf1e (patch)
tree05468c430a420a3bf4f10bdeacb21ce9ca0283c9 /packages/udev/udev-065
parent7d5fdf15cfcf298a8da8d3525f7ff36537fff81c (diff)
udev: Prune old obsolete broken versions (058, 063, 065, 070, 071).
Diffstat (limited to 'packages/udev/udev-065')
-rw-r--r--packages/udev/udev-065/.mtn2git_empty0
-rw-r--r--packages/udev/udev-065/flags.patch66
-rw-r--r--packages/udev/udev-065/init178
-rw-r--r--packages/udev/udev-065/tty-symlinks.patch11
4 files changed, 0 insertions, 255 deletions
diff --git a/packages/udev/udev-065/.mtn2git_empty b/packages/udev/udev-065/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/udev/udev-065/.mtn2git_empty
+++ /dev/null
diff --git a/packages/udev/udev-065/flags.patch b/packages/udev/udev-065/flags.patch
deleted file mode 100644
index d95daa51e2..0000000000
--- a/packages/udev/udev-065/flags.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- udev-065/Makefile~flags
-+++ udev-065/Makefile
-@@ -106,11 +106,11 @@
- # check if compiler option is supported
- cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi;}
-
--CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
-+override CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
- -Wstrict-prototypes -Wsign-compare
--CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
--CFLAGS += -pipe
--CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
-+override CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
-+override CFLAGS += -pipe
-+override CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
-
- # use '-Os' optimization if available, else use -O2
- OPTFLAGS := $(call cc-supports, -Os, -O2)
-@@ -154,16 +154,16 @@
-
- SYSFS = $(PWD)/libsysfs/sysfs.a
-
--CFLAGS += -I$(PWD)/libsysfs/sysfs \
-+override CFLAGS += -I$(PWD)/libsysfs/sysfs \
- -I$(PWD)/libsysfs
-
- ifeq ($(strip $(USE_LOG)),true)
-- CFLAGS += -DUSE_LOG
-+ override CFLAGS += -DUSE_LOG
- endif
-
- # if DEBUG is enabled, then we do not strip or optimize
- ifeq ($(strip $(DEBUG)),true)
-- CFLAGS += -O1 -g -DDEBUG
-+ override CFLAGS += -DDEBUG
- LDFLAGS += -Wl
- STRIPCMD = /bin/true -Since_we_are_debugging
- else
-@@ -180,18 +180,18 @@
- CC = $(KLCC)
- LD = $(KLCC)
- else
-- CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-+ override CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
- endif
-
- ifeq ($(strip $(USE_SELINUX)),true)
- UDEV_OBJS += udev_selinux.o
- LIB_OBJS += -lselinux
-- CFLAGS += -DUSE_SELINUX
-+ override CFLAGS += -DUSE_SELINUX
- endif
-
- ifeq ($(strip $(USE_STATIC)),true)
-- CFLAGS += -DUSE_STATIC
-- LDFLAGS += -static
-+ override CFLAGS += -DUSE_STATIC
-+ override LDFLAGS += -static
- endif
-
- ifeq ($(strip $(V)),false)
diff --git a/packages/udev/udev-065/init b/packages/udev/udev-065/init
deleted file mode 100644
index 67886c9e54..0000000000
--- a/packages/udev/udev-065/init
+++ /dev/null
@@ -1,178 +0,0 @@
-#!/bin/sh -e
-
-PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-
-UDEVSTART=/sbin/udevstart
-
-# default maximum size of the /dev ramfs
-ramfs_size="1M"
-
-[ -x $UDEVSTART ] || exit 0
-
-. /etc/udev/udev.conf
-
-case "$(uname -r)" in
- 2.[012345].*)
- echo "udev requires a kernel >= 2.6, not started."
- exit 0
- ;;
-esac
-
-if ! grep -q '[[:space:]]ramfs$' /proc/filesystems; then
- echo "udev requires ramfs support, not started."
- exit 0
-fi
-
-if [ ! -e /proc/sys/kernel/hotplug ] && [ ! -e /sys/kernel/uevent_helper ]; then
- echo "udev requires hotplug support, not started."
- exit 0
-fi
-
-##############################################################################
-
-# we need to unmount /dev/pts/ and remount it later over the ramfs
-unmount_devpts() {
- if mountpoint -q /dev/pts/; then
- umount -l /dev/pts/
- fi
-
- if mountpoint -q /dev/shm/; then
- umount -l /dev/shm/
- fi
-}
-
-# mount a ramfs over /dev, if somebody did not already do it
-mount_ramfs() {
- if grep -E -q "^[^[:space:]]+ /dev ramfs" /proc/mounts; then
- return 0
- fi
-
- # /.dev is used by /sbin/MAKEDEV to access the real /dev directory.
- # if you don't like this, remove /.dev/.
- [ -d /.dev ] && mount --bind /dev /.dev
-
- echo -n "Mounting a ramfs over /dev..."
- mount -n -o size=$ramfs_size,mode=0755 -t ramfs none /dev
- echo "done."
-}
-
-# I hate this hack. -- Md
-make_extra_nodes() {
- if [ -f /etc/udev/links.conf ]; then
- grep '^[^#]' /etc/udev/links.conf | \
- while read type name arg1; do
- [ "$type" -a "$name" -a ! -e "/dev/$name" -a ! -L "/dev/$name" ] ||continue
- case "$type" in
- L)
- ln -s $arg1 /dev/$name
- ;;
- D)
- mkdir -p /dev/$name
- ;;
- M)
- mknod -m 600 /dev/$name $arg1
- ;;
- *)
- echo "unparseable line ($type $name $arg1)"
- ;;
- esac
- done
- fi
-}
-
-##############################################################################
-
-if [ "$udev_root" != "/dev" ]; then
- echo "WARNING: udev_root != /dev"
-
-case "$1" in
- start)
- if [ -e "$udev_root/.udev.tdb" ]; then
- if mountpoint -q /dev/; then
- echo "FATAL: udev is already active on $udev_root."
- exit 1
- else
- echo "WARNING: .udev.tdb already exists on the old $udev_root!"
- fi
- fi
- mount -n -o size=$ramfs_size,mode=0755 -t ramfs none $udev_root
- echo -n "Creating initial device nodes..."
- $UDEVSTART
- echo "done."
- ;;
- stop)
- start-stop-daemon -K -x /sbin/udevd
- echo -n "Unmounting $udev_root..."
- # unmounting with -l should never fail
- if umount -l $udev_root; then
- echo "done."
- else
- echo "failed."
- fi
- ;;
- restart|force-reload)
- $0 stop
- $0 start
- ;;
- *)
- echo "Usage: /etc/init.d/udev {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
- exit 0
-fi # udev_root != /dev/
-
-##############################################################################
-# When modifying this script, do not forget that between the time that
-# the new /dev has been mounted and udevstart has been run there will be
-# no /dev/null. This also means that you cannot use the "&" shell command.
-
-case "$1" in
- start)
- if [ -e "$udev_root/.udev.tdb" ]; then
- if mountpoint -q /dev/; then
- echo "FATAL: udev is already active on $udev_root."
- exit 1
- else
- echo "WARNING: .udev.tdb already exists on the old $udev_root!"
- fi
- fi
- unmount_devpts
- mount_ramfs
- ACTION=add
- echo -n "Creating initial device nodes..."
- $UDEVSTART
- make_extra_nodes
- echo "done."
-# /etc/init.d/mountvirtfs start
- ;;
- stop)
- start-stop-daemon -K -x /sbin/udevd
- unmount_devpts
- echo -n "Unmounting /dev..."
- # unmounting with -l should never fail
- if umount -l /dev; then
- echo "done."
- umount -l /.dev || true
-# /etc/init.d/mountvirtfs start
- else
- echo "failed."
- fi
- ;;
- restart|force-reload)
- start-stop-daemon -K -x /sbin/udevd
- echo -n "Recreating device nodes..."
- ACTION=add
- $UDEVSTART
- make_extra_nodes
- echo "done."
- ;;
- *)
- echo "Usage: /etc/init.d/udev {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
-
diff --git a/packages/udev/udev-065/tty-symlinks.patch b/packages/udev/udev-065/tty-symlinks.patch
deleted file mode 100644
index 6a458de64c..0000000000
--- a/packages/udev/udev-065/tty-symlinks.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- udev-063/etc/udev/udev.rules.devfs.orig 2005-07-27 19:55:51 +0200
-+++ udev-063/etc/udev/udev.rules.devfs 2005-07-27 19:56:49 +0200
-@@ -103,3 +103,8 @@
-
- # raw devices
- KERNEL="raw[0-9]*", NAME="raw/%k"
-+
-+# tty devices
-+KERNEL=="tty[0-9]*", SYMLINK="%k"
-+KERNEL=="ttyS[0-9]*", SYMLINK="%k"
-+