summaryrefslogtreecommitdiff
path: root/packages/uclibc/uclibc.inc
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 21:54:39 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 21:54:39 +0000
commitcb82144c79b159a634275390a7ac55f639192d0c (patch)
treeda60d126aa2e6a47d9fcaa068b48dac4b3f56cb3 /packages/uclibc/uclibc.inc
parent99a2c8c9cda0133d249b854e031d1a35632b9dfa (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 15:31:35-06:00 ti.com!kergoth Apply fix to lame from Michael Kropfberg that ensures that the library packages get emitted. 2005/02/23 14:04:22-06:00 ti.com!kergoth Use the recent glibc snaps by default for the sh3 and sh4 target architectures. 2005/02/23 13:49:33-06:00 ti.com!kergoth Fix the unpleasant target path mangling in do_install in the uclibc builds to happen only when necessary (thereby unborking the uclibc build with default paths). 2005/02/23 13:30:16-06:00 ti.com!kergoth modutils: apply patch from Hermann Lacheiner to fix another missing /. 2005/02/23 12:36:57-06:00 ti.com!kergoth Add sh3 uclibc defconfigs for all the uclibc versions. 2005/02/23 12:27:56-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/projects/oe/openembedded 2005/02/23 12:27:44-06:00 ti.com!kergoth module-init-tools: fix another bug caused by that rampant sed'ing. 2005/02/23 18:57:22+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 18:57:02+01:00 uni-frankfurt.de!mickeyl introduce IPKGBUILDCMD to enable overwriting the ipkg-build command line arguments. tweak sharprom-compatible.conf to override IPKGBUILDCMD. thanksfully, ipkg-build still supports the outdated format 2005/02/23 10:32:16-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/projects/oe/openembedded 2005/02/23 10:31:54-06:00 ti.com!kergoth Bump PR in the packages that were broken by the hokey sed from yesterday. 2005/02/23 17:14:56+01:00 uni-frankfurt.de!mickeyl misc opie files: use palmtopdir variable instead of hardcoding /opt/QtPalmtop/ 2005/02/23 17:05:25+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 09:56:05-06:00 ti.com!kergoth Fixes per the overenthusiastic sed / removal I did yesterday. Thanks to Hermann Lacheiner and Holger Schurig for spotting a couple of them, this should fix the others. 2005/02/23 16:48:08+01:00 uni-frankfurt.de!mickeyl make the prism3-support package work BKrev: 421cfb9f-K6bfhnkhAVPJV_fqpHn7Q
Diffstat (limited to 'packages/uclibc/uclibc.inc')
-rw-r--r--packages/uclibc/uclibc.inc29
1 files changed, 18 insertions, 11 deletions
diff --git a/packages/uclibc/uclibc.inc b/packages/uclibc/uclibc.inc
index a308926b86..04b5492da3 100644
--- a/packages/uclibc/uclibc.inc
+++ b/packages/uclibc/uclibc.inc
@@ -152,16 +152,23 @@ do_install() {
# This conflicts with the c++ version of this header
rm -f ${D}${prefix}/include/bits/atomicity.h
- install -d ${D}${includedir}
- mv ${D}${prefix}/include/* ${D}${includedir}/
- rmdir ${D}${prefix}/include
-
- install -d ${D}${libdir}
- mv ${D}${prefix}/lib/* ${D}${libdir}/
- rmdir ${D}${prefix}/lib
-
- install -d ${D}${bindir}
- mv ${D}usr/bin/* ${D}${bindir}/
- rmdir ${D}usr/bin
+ # ugh.. uclibc doesn't like obeying our path variables.
+ if [ "${includedir}" != "${prefix}/include" ]; then
+ install -d ${D}${includedir}
+ mv ${D}${prefix}/include/* ${D}${includedir}/
+ rmdir ${D}${prefix}/include
+ fi
+
+ if [ "${libdir}" != "${prefix}/lib" ]; then
+ install -d ${D}${libdir}
+ mv ${D}${prefix}/lib/* ${D}${libdir}/
+ rmdir ${D}${prefix}/lib
+ fi
+
+ if [ "${bindir}" != "/usr/bin" ]; then
+ install -d ${D}${bindir}
+ mv ${D}/usr/bin/* ${D}${bindir}/
+ rmdir ${D}/usr/bin
+ fi
}