summaryrefslogtreecommitdiff
path: root/packages/uboot
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-30 16:27:55 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-30 16:27:55 +0000
commit71dc066d7015b1b544f64cd4e47b8af483ccbb2b (patch)
treef01b3ad5a78141f2dad7d96b5ca92cd88e0d67a2 /packages/uboot
parent8707920ac505691fcfd99d3892098b297b2022a3 (diff)
uboot-utils: Update and move to uboot/
Diffstat (limited to 'packages/uboot')
-rw-r--r--packages/uboot/uboot-utils_1.1.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/uboot/uboot-utils_1.1.2.bb b/packages/uboot/uboot-utils_1.1.2.bb
new file mode 100644
index 0000000000..8a5d7dce3c
--- /dev/null
+++ b/packages/uboot/uboot-utils_1.1.2.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "U-boot bootloader OS env. access tools for PPC"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "mtd-utils"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/u-boot/u-boot-${PV}.tar.bz2 \
+ file://fw_env.c.patch;patch=1 \
+ file://tools-Makefile.patch;patch=1 \
+ file://env-Makefile.patch;patch=1 \
+ file://fw_env.config"
+
+S = "${WORKDIR}/u-boot-${PV}"
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
+
+UBOOT_MACHINE ?= "${MACHINE}_config"
+
+inherit base
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ oe_runmake Sandpoint8240_config
+ oe_runmake tools
+}
+
+# install mkimage for the kernel makefile
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 ${S}/tools/mkimage ${STAGING_BINDIR_NATIVE}/
+}
+
+do_install () {
+ install -d ${D}/sbin
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
+}