summaryrefslogtreecommitdiff
path: root/packages/uboot/uboot-utils_1.2.0.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-04-10 17:45:19 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-04-10 17:45:19 +0000
commitea816aafec72ce5e90e8018f890c10c28fdfe218 (patch)
treedf32a24086df48a7d4aeac79aa2af6f645bd4140 /packages/uboot/uboot-utils_1.2.0.bb
parent47f4090dc92198099ede07f4afd65d34bfb4ef29 (diff)
u-boot: finish moving u-boot utils
Diffstat (limited to 'packages/uboot/uboot-utils_1.2.0.bb')
-rw-r--r--packages/uboot/uboot-utils_1.2.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/uboot/uboot-utils_1.2.0.bb b/packages/uboot/uboot-utils_1.2.0.bb
new file mode 100644
index 0000000000..8a5d7dce3c
--- /dev/null
+++ b/packages/uboot/uboot-utils_1.2.0.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "U-boot bootloader OS env. access tools for PPC"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "mtd-utils"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/u-boot/u-boot-${PV}.tar.bz2 \
+ file://fw_env.c.patch;patch=1 \
+ file://tools-Makefile.patch;patch=1 \
+ file://env-Makefile.patch;patch=1 \
+ file://fw_env.config"
+
+S = "${WORKDIR}/u-boot-${PV}"
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+TARGET_LDFLAGS = ""
+
+UBOOT_MACHINE ?= "${MACHINE}_config"
+
+inherit base
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ oe_runmake Sandpoint8240_config
+ oe_runmake tools
+}
+
+# install mkimage for the kernel makefile
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 ${S}/tools/mkimage ${STAGING_BINDIR_NATIVE}/
+}
+
+do_install () {
+ install -d ${D}/sbin
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
+}