summaryrefslogtreecommitdiff
path: root/packages/uboot/u-boot-utils-native_1.2.0.bb
diff options
context:
space:
mode:
authorAndrew Wilcox <andy@protium.com>2007-12-17 06:05:26 +0000
committerAndrew Wilcox <andy@protium.com>2007-12-17 06:05:26 +0000
commit5206b0d92ce6a6622ec041231314d7242a35f0e8 (patch)
tree94edc2ae7c369c2c6fe5a831d68ba3c6ebc60de6 /packages/uboot/u-boot-utils-native_1.2.0.bb
parent2eef78ec91e7fc70a5ccc318e78f43d55d44b8b2 (diff)
Rename uboot-utils to u-boot-utils-native. u-boot-utils now makes
target u-boot utility fw_setenv for one distro.
Diffstat (limited to 'packages/uboot/u-boot-utils-native_1.2.0.bb')
-rw-r--r--packages/uboot/u-boot-utils-native_1.2.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/uboot/u-boot-utils-native_1.2.0.bb b/packages/uboot/u-boot-utils-native_1.2.0.bb
new file mode 100644
index 0000000000..02f9748ae3
--- /dev/null
+++ b/packages/uboot/u-boot-utils-native_1.2.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "U-boot bootloader mkimage utility"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "GPL"
+ALLOW_EMPTY = "1"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+inherit native
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ oe_runmake Sandpoint8240_config
+ oe_runmake tools
+}
+
+# install mkimage for the kernel makefile
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 ${S}/tools/mkimage ${STAGING_BINDIR_NATIVE}/
+}
+