summaryrefslogtreecommitdiff
path: root/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-03-07 09:40:43 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-03-07 09:40:43 +0000
commit45a14d8d7ddd343a723964e81c38d5ed87e23a55 (patch)
tree62dd486e97501aed92d19bdae1452aac1299219b /packages/uboot/u-boot-mkimage-gta01-native_svn.bb
parent42f9ffa88b51752842deb20797feafd528b8e7b9 (diff)
u-boot-mkimage-gta01: renamed to u-boot-mkimage-gta01-native
Diffstat (limited to 'packages/uboot/u-boot-mkimage-gta01-native_svn.bb')
-rw-r--r--packages/uboot/u-boot-mkimage-gta01-native_svn.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/uboot/u-boot-mkimage-gta01-native_svn.bb b/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
new file mode 100644
index 0000000000..ad98bea30e
--- /dev/null
+++ b/packages/uboot/u-boot-mkimage-gta01-native_svn.bb
@@ -0,0 +1,18 @@
+require uboot-gta01_svn.bb
+
+PROVIDES = ""
+TARGET_LDFLAGS = ""
+
+do_compile () {
+ chmod +x board/neo1973/split_by_variant.sh
+ oe_runmake gta01bv3_config
+ oe_runmake clean
+ oe_runmake tools
+}
+
+do_deploy () {
+ install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
+}
+
+do_deploy[dirs] = "${S}"
+addtask deploy before do_build after do_compile