summaryrefslogtreecommitdiff
path: root/packages/uboot/files
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-10-16 15:17:36 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-10-16 15:17:36 +0000
commit08133da144d95bbbdc83a74fab1f9851e90aa3c6 (patch)
tree61c57e5a83ddc1c338d9fcc26c4845c71f0f062d /packages/uboot/files
parent3e5c600bfffcbfea69f1dc0ae2016a1b9169b413 (diff)
uboot/files/makefile-no-dirafter.patch : this patch is more general
Diffstat (limited to 'packages/uboot/files')
-rw-r--r--packages/uboot/files/makefile-no-dirafter.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/uboot/files/makefile-no-dirafter.patch b/packages/uboot/files/makefile-no-dirafter.patch
new file mode 100644
index 0000000000..2ed26c3127
--- /dev/null
+++ b/packages/uboot/files/makefile-no-dirafter.patch
@@ -0,0 +1,17 @@
+Index: git/tools/Makefile
+===================================================================
+--- git.orig/tools/Makefile 2007-10-03 16:51:38.000000000 +0100
++++ git/tools/Makefile 2007-10-03 16:52:03.000000000 +0100
+@@ -114,9 +114,9 @@
+ #
+ # Use native tools and options
+ #
+-CPPFLAGS = -idirafter $(SRCTREE)/include \
+- -idirafter $(OBJTREE)/include2 \
+- -idirafter $(OBJTREE)/include \
++CPPFLAGS = -I$(SRCTREE)/include \
++ -I$(OBJTREE)/include2 \
++ -I$(OBJTREE)/include \
+ -DTEXT_BASE=$(TEXT_BASE) -DUSE_HOSTCC
+ CFLAGS = $(HOST_CFLAGS) $(CPPFLAGS) -O
+ AFLAGS = -D__ASSEMBLY__ $(CPPFLAGS)