summaryrefslogtreecommitdiff
path: root/packages/uboot-utils/files
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-08 19:51:17 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-08 19:51:17 +0000
commit6a66295bdb7a68583be6fd92a0090b258f72c33b (patch)
treee3f776a8ecae67a0c40e572179919ae5c6d6e9e6 /packages/uboot-utils/files
parent16c7704c59a0132f8115ec7aa46a667fb8d2383d (diff)
uboot-utils: Make it usable on other machines than the storcenter
Diffstat (limited to 'packages/uboot-utils/files')
-rw-r--r--packages/uboot-utils/files/.mtn2git_empty0
-rw-r--r--packages/uboot-utils/files/env-Makefile.patch24
-rw-r--r--packages/uboot-utils/files/fw_env.c.patch13
-rw-r--r--packages/uboot-utils/files/fw_env.h.patch24
-rw-r--r--packages/uboot-utils/files/tools-Makefile.patch19
5 files changed, 80 insertions, 0 deletions
diff --git a/packages/uboot-utils/files/.mtn2git_empty b/packages/uboot-utils/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/uboot-utils/files/.mtn2git_empty
diff --git a/packages/uboot-utils/files/env-Makefile.patch b/packages/uboot-utils/files/env-Makefile.patch
new file mode 100644
index 0000000000..ad3a6b39a3
--- /dev/null
+++ b/packages/uboot-utils/files/env-Makefile.patch
@@ -0,0 +1,24 @@
+--- u-boot-1.1.2.orig/tools/env/Makefile 2003-06-27 14:32:48.000000000 -0700
++++ u-boot-1.1.2/tools/env/Makefile 2006-11-08 12:33:43.000000000 -0800
+@@ -27,7 +27,7 @@
+ all: fw_printenv
+
+ fw_printenv: $(SOURCES) $(HEADERS)
+- $(CROSS_COMPILE)gcc -Wall -DUSE_HOSTCC $(SOURCES) -o fw_printenv
++ $(CROSS_COMPILE)gcc $(TARGET_CFLAGS) -idirafter ../../include -Wall -DUSE_HOSTCC $(SOURCES) -o fw_printenv
+
+ clean:
+ rm -f fw_printenv crc32.c
+@@ -37,9 +37,9 @@
+
+ #########################################################################
+
+-.depend: Makefile $(SOURCES)
+- $(CC) -M $(HOST_CFLAGS) $(CPPFLAGS) -DUSE_HOSTCC $(SOURCES) > $@
++#.depend: Makefile $(SOURCES)
++# $(CC) -M $(HOST_CFLAGS) $(TARGET_CPPFLAGS) -DUSE_HOSTCC $(SOURCES) > $@
+
+-sinclude .depend
++#sinclude .depend
+
+ #########################################################################
diff --git a/packages/uboot-utils/files/fw_env.c.patch b/packages/uboot-utils/files/fw_env.c.patch
new file mode 100644
index 0000000000..62f364ad4a
--- /dev/null
+++ b/packages/uboot-utils/files/fw_env.c.patch
@@ -0,0 +1,13 @@
+--- u-boot-1.1.2.orig/tools/env/fw_env.c 2004-12-31 01:32:54.000000000 -0800
++++ u-boot-1.1.2/tools/env/fw_env.c 2006-11-08 12:43:41.000000000 -0800
+@@ -31,7 +31,9 @@
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+-#include <linux/mtd/mtd.h>
++#include <stdint.h>
++#include <mtd/mtd-abi.h>
++#include <mtd/mtd-user.h>
+ #include "fw_env.h"
+
+ typedef unsigned char uchar;
diff --git a/packages/uboot-utils/files/fw_env.h.patch b/packages/uboot-utils/files/fw_env.h.patch
new file mode 100644
index 0000000000..2ef2bb83c4
--- /dev/null
+++ b/packages/uboot-utils/files/fw_env.h.patch
@@ -0,0 +1,24 @@
+--- u-boot-1.1.2.orig/tools/env/fw_env.h 2003-06-27 14:32:49.000000000 -0700
++++ u-boot-1.1.2/tools/env/fw_env.h 2006-11-16 10:51:01.000000000 -0800
+@@ -27,14 +27,15 @@
+ * See included "fw_env.config" sample file (TRAB board)
+ * for notes on configuration.
+ */
+-#define CONFIG_FILE "/etc/fw_env.config"
+
+-#define HAVE_REDUND /* For systems with 2 env sectors */
+-#define DEVICE1_NAME "/dev/mtd1"
++/* #define CONFIG_FILE "/etc/fw_env.config" */
++
++#undef HAVE_REDUND /* For systems with 2 env sectors */
++#define DEVICE1_NAME "/dev/mtd/3"
+ #define DEVICE2_NAME "/dev/mtd2"
+-#define DEVICE1_OFFSET 0x0000
+-#define ENV1_SIZE 0x4000
+-#define DEVICE1_ESIZE 0x4000
++#define DEVICE1_OFFSET 0x30000
++#define ENV1_SIZE 0x10000
++#define DEVICE1_ESIZE 0x10000
+ #define DEVICE2_OFFSET 0x0000
+ #define ENV2_SIZE 0x4000
+ #define DEVICE2_ESIZE 0x4000
diff --git a/packages/uboot-utils/files/tools-Makefile.patch b/packages/uboot-utils/files/tools-Makefile.patch
new file mode 100644
index 0000000000..a44bc917d6
--- /dev/null
+++ b/packages/uboot-utils/files/tools-Makefile.patch
@@ -0,0 +1,19 @@
+--- u-boot-1.1.2.orig/tools/Makefile 2004-09-28 14:39:46.000000000 -0700
++++ u-boot-1.1.2/tools/Makefile 2006-11-08 11:07:18.000000000 -0800
+@@ -56,7 +56,7 @@
+ HOSTOS := $(shell uname -s | tr A-Z a-z | \
+ sed -e 's/\(cygwin\).*/cygwin/')
+
+-TOOLSUBDIRS =
++TOOLSUBDIRS = env
+
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific. It
+@@ -176,6 +176,7 @@
+ else
+ @for dir in $(TOOLSUBDIRS) ; do \
+ $(MAKE) \
++ CROSS_COMPILE=$(CROSS_COMPILE) \
+ HOSTOS=$(HOSTOS) \
+ HOSTARCH=$(HOSTARCH) \
+ HOST_CFLAGS="$(HOST_CFLAGS)" \