summaryrefslogtreecommitdiff
path: root/packages/u-boot/u-boot_1.1.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/u-boot/u-boot_1.1.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/u-boot/u-boot_1.1.2.bb')
-rw-r--r--packages/u-boot/u-boot_1.1.2.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/packages/u-boot/u-boot_1.1.2.bb b/packages/u-boot/u-boot_1.1.2.bb
deleted file mode 100644
index c83e31f532..0000000000
--- a/packages/u-boot/u-boot_1.1.2.bb
+++ /dev/null
@@ -1,59 +0,0 @@
-PR = "r3"
-require u-boot.inc
-
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
- file://arm_flags.patch;patch=1 "
-# Override whole URI fr Neon since Neon patch is incompatible with arm_flags patch.
-SRC_URI_bd-neon = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
- file://u-boot-1.1.2-neon.patch;patch=1"
-SRC_URI_append_vibren = "ftp://bec-systems.com/pub/pxa255_idp/u-boot/uboot_pxa255-idp_2005-03-23.patch;patch=1"
-SRC_URI_append_mnci = "file://mnci.patch;patch=1 \
- file://mnci-jffs2.patch;patch=1 \
- file://cmd-arm-linux.patch;patch=1 \
- file://command-names.patch;patch=1"
-
-SRC_URI_append_magicbox = "file://u-boot-emetec.patch;patch=1 "
-SRC_URI_append_oxnas = "file://oxnas.patch;patch=1 "
-
-
-# TODO: SRC_URI_append_rt3000
-
-TARGET_LDFLAGS = ""
-
-UBOOT_MACHINE_mnci = "mnci_config"
-UBOOT_MACHINE_vibren = "pxa255_idp_config"
-UBOOT_MACHINE_magicbox = "EMETEC405_config"
-UBOOT_MACHINE_oxnas = "oxnas_config"
-
-inherit base
-
-do_compile () {
- oe_runmake ${UBOOT_MACHINE}
- oe_runmake all
-}
-
-#########################################################
-
-RDEPENDS_append_mnci = " hwctrl"
-
-FILES_${PN}_mnci = "/tmp/${UBOOT_IMAGE}"
-
-do_configure_prepend_bd-neon () {
- chmod +x ${S}/Configure
-}
-
-do_install_openmn() {
- install -d ${D}/tmp
- install ${S}/u-boot.bin ${D}/tmp/${UBOOT_IMAGE}
-}
-
-pkg_postinst_mnci() {
-ldconfig
-A=/tmp/bootargs
-hwctrl kernel_conf_get bootargs >$A
-cp /tmp/${UBOOT_IMAGE} /dev/mtdblock/0
-rm /tmp/${UBOOT_IMAGE}
-hwctrl kernel_conf_set bootargs "`cat $A`"
-cat /dev/mtdblock/0 >/dev/null
-exit 0
-}