summaryrefslogtreecommitdiff
path: root/packages/u-boot/u-boot-openmoko-devel_git.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-20 21:57:52 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-20 21:57:52 +0000
commitd9bf097029dc46a6fd3eb4a0e7b02bad58e6327c (patch)
tree1b2e8e87fc0eb969a565d503f120e7838a8bc840 /packages/u-boot/u-boot-openmoko-devel_git.bb
parentc5f8d1b4300f9f5912800e17a9bf91cceee0abb6 (diff)
u-boot-openmoko * remove deprecated svn versions, add git versions
Diffstat (limited to 'packages/u-boot/u-boot-openmoko-devel_git.bb')
-rw-r--r--packages/u-boot/u-boot-openmoko-devel_git.bb70
1 files changed, 3 insertions, 67 deletions
diff --git a/packages/u-boot/u-boot-openmoko-devel_git.bb b/packages/u-boot/u-boot-openmoko-devel_git.bb
index c1a5cefe77..3659241dfa 100644
--- a/packages/u-boot/u-boot-openmoko-devel_git.bb
+++ b/packages/u-boot/u-boot-openmoko-devel_git.bb
@@ -1,72 +1,8 @@
-DESCRIPTION = "U-boot bootloader w/ Neo1973 (GTA01) and Neo FreeRunner (GTA02) support"
-AUTHOR = "Harald Welte <laforge@openmoko.org>"
-LICENSE = "GPL"
-SECTION = "bootloader"
-PRIORITY = "optional"
-PROVIDES = "virtual/bootloader"
-LOCALVERSION = "+git${SRCREV}"
-PV = "1.3.1${LOCALVERSION}"
-PR = "r1"
+require u-boot-openmoko.inc
-UBOOT_MACHINES = "gta01bv2 gta01bv3 gta01bv4 gta02v2 gta02v4 gta02v5"
-
-DEFAULT_PREFERENCE = "-1"
-
-SRCREV_FORMAT = "git.openmoko.org"
-
-SRCREV = "1dd080c17b105da5cd4720307fa62de38276796a"
-
-SRC_URI = "git://git.openmoko.org/git/u-boot.git;protocol=git;branch=andy \
- file://uboot-20070311-tools_makefile_ln_sf.patch;patch=1 \
+SRC_URI = "\
+ git://git.openmoko.org/git/u-boot.git;protocol=git;branch=andy \
file://makefile-no-dirafter.patch;patch=1 \
"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-TARGET_LDFLAGS = ""
-
-do_svnrev() {
- mv -f tools/setlocalversion tools/setlocalversion.old
- echo "echo ${LOCALVERSION}" >>tools/setlocalversion
-}
-
-do_compile () {
- chmod +x board/neo1973/gta*/split_by_variant.sh
- for mach in ${UBOOT_MACHINES}
- do
- oe_runmake ${mach}_config
- oe_runmake clean
- find board -name lowlevel_foo.bin -exec rm '{}' \;
- oe_runmake all
- oe_runmake u-boot.udfu
- if [ -f u-boot.udfu ]; then
- mv u-boot.udfu u-boot_${mach}.bin
- else
- mv u-boot.bin u-boot_${mach}.bin
- fi
- if [ -f board/${mach}/lowlevel_foo.bin ]; then
- mv board/${mach}/lowlevel_foo.bin lowlevel_foo_${mach}.bin
- else
- find board -name lowlevel_foo.bin -exec mv '{}' lowlevel_foo_${mach}.bin \;
- fi
- done
-}
-
-do_deploy () {
- install -d ${DEPLOY_DIR_IMAGE}
- for mach in ${UBOOT_MACHINES}
- do
- install -m 0644 ${S}/u-boot_${mach}.bin ${DEPLOY_DIR_IMAGE}/u-boot-${mach}-${PV}-${PR}.bin
- ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${mach}-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-${mach}-latest.bin
- if [ -f ${S}/lowlevel_foo_${mach}.bin ]; then
- install -m 0644 ${S}/lowlevel_foo_${mach}.bin ${DEPLOY_DIR_IMAGE}/lowlevel_foo-${mach}-${PV}-${PR}.bin
- ln -sf ${DEPLOY_DIR_IMAGE}/lowlevel_foo-${mach}-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/lowlevel-foo-${mach}-latest.bin
- fi
- done
- install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
-}
-
-do_deploy[dirs] = "${S}"
-addtask deploy before do_package after do_install
-addtask quilt before do_patch after do_unpack
-addtask svnrev before do_patch after do_quilt