summaryrefslogtreecommitdiff
path: root/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-08 08:32:16 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-08 08:32:16 +0000
commit99080914085100da9cacf91243f0ead3b02abae8 (patch)
treed0806a6fd48a87ac5116f6e7fa404defb0dfebf1 /packages/ttf-fonts/ttf-bitstream-vera_1.10.bb
parente2a93800d6958ce44b0c605f42ce1b04013f4463 (diff)
parent6e5b132accfc498a843b84477d1aee909068711c (diff)
merge of '2415386acd7ccac3f0f71353ad8ac290a875573d'
and '4cd70362c1066d1d95aea3f4308c3007d06592ce'
Diffstat (limited to 'packages/ttf-fonts/ttf-bitstream-vera_1.10.bb')
-rw-r--r--packages/ttf-fonts/ttf-bitstream-vera_1.10.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb b/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb
new file mode 100644
index 0000000000..871bc1d37c
--- /dev/null
+++ b/packages/ttf-fonts/ttf-bitstream-vera_1.10.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The Bitstream Vera fonts - TTF Edition"
+SECTION = "x11/fonts"
+PRIORITY = "optional"
+LICENSE = "Bitstream Vera"
+PACKAGE_ARCH = "all"
+PR = "r3"
+RDEPENDS = "fontconfig-utils"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
+
+do_install () {
+ install -d ${D}${prefix}/share/fonts/ttf/
+ for i in *.ttf; do
+ install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+
+ # fontconfig ships this too. not sure what to do about it.
+ #install -d ${D}${sysconfdir}/fonts
+ #install -m 644 local.conf ${D}${sysconfdir}/fonts/local.conf
+
+
+ install -d ${D}${prefix}/share/doc/${PN}/
+ for i in *.TXT; do
+ install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i
+ done
+}
+
+pkg_postinst () {
+#!/bin/sh
+fc-cache
+}
+
+
+FILES_${PN} = "/etc ${datadir}/fonts"