summaryrefslogtreecommitdiff
path: root/packages/tslib
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-23 21:37:39 +0000
committerKoen Kooi <koen@openembedded.org>2006-07-23 21:37:39 +0000
commit5d259c4c1c25e7048c492e143ebda5f6f012ed59 (patch)
tree8d64c323b802a7a67d813bf5fe8c7281de35d9f0 /packages/tslib
parentd1b3f3d206504e1ff0ff4d1e73e45c40eb936af7 (diff)
tslib: add support for h5xxx
Diffstat (limited to 'packages/tslib')
-rw-r--r--packages/tslib/tslib/h5xxx/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/h5xxx/tslib.sh19
-rw-r--r--packages/tslib/tslib_20060703.bb3
3 files changed, 21 insertions, 1 deletions
diff --git a/packages/tslib/tslib/h5xxx/.mtn2git_empty b/packages/tslib/tslib/h5xxx/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/h5xxx/.mtn2git_empty
diff --git a/packages/tslib/tslib/h5xxx/tslib.sh b/packages/tslib/tslib/h5xxx/tslib.sh
new file mode 100644
index 0000000000..0de3534a51
--- /dev/null
+++ b/packages/tslib/tslib/h5xxx/tslib.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+module_id() {
+ awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
+}
+
+case `uname -r` in
+2.4*)
+ TSLIB_TSDEVICE=/dev/touchscreen/0raw
+ TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600-2.4
+ ;;
+*)
+ TSLIB_TSDEVICE=`detect-stylus --device`
+ TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
+ ;;
+esac
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
+
diff --git a/packages/tslib/tslib_20060703.bb b/packages/tslib/tslib_20060703.bb
index d756a5c576..55884a8b49 100644
--- a/packages/tslib/tslib_20060703.bb
+++ b/packages/tslib/tslib_20060703.bb
@@ -38,7 +38,7 @@ do_install_append() {
install -d ${D}${sysconfdir}/profile.d/
install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
case ${MACHINE} in
- a780 | e680 | h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel | h4000)
+ a780 | e680 | h3600 | h3900 | h5xxx | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel | h4000)
install -d ${D}${datadir}/tslib
for f in ts-2.6.conf ts.conf-h3600-2.4; do
install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
@@ -79,6 +79,7 @@ RDEPENDS_tslib-conf_h1940 = "detect-stylus"
RDEPENDS_tslib-conf_h2200 = "detect-stylus"
RDEPENDS_tslib-conf_h3600 = "detect-stylus"
RDEPENDS_tslib-conf_h3900 = "detect-stylus"
+RDEPENDS_tslib-conf_h5xxx = "detect-stylus"
RDEPENDS_tslib-conf_h6300 = "detect-stylus"
RDEPENDS_tslib-conf_blueangel = "detect-stylus"
RDEPENDS_tslib-conf_htcuniversal = "detect-stylus"