summaryrefslogtreecommitdiff
path: root/packages/totem/totem_2.23.4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-10 15:47:43 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-10 15:47:43 +0000
commit70185fab5a60f21c0888baa34d621450b7205716 (patch)
treeae1c86e00db1724d3183ad98abe66a629fa1626a /packages/totem/totem_2.23.4.bb
parent60ead6c3df9298dbbbf284ddd6d1415ca604f5bb (diff)
totem: add 2.23.4
Diffstat (limited to 'packages/totem/totem_2.23.4.bb')
-rw-r--r--packages/totem/totem_2.23.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/totem/totem_2.23.4.bb b/packages/totem/totem_2.23.4.bb
new file mode 100644
index 0000000000..7bd5c6945b
--- /dev/null
+++ b/packages/totem/totem_2.23.4.bb
@@ -0,0 +1,35 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = " totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS = "iso-codes"
+RRECOMMENDS = "gst-plugin-playbin gst-ffmpeg gst-plugin-audioresample gst-plugin-ximagesink gst-plugin-xvimagesink gst-plugin-alsa"
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+EXTRA_OECONF=" --disable-schemas-install \
+ --enable-gtk \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-gstreamer \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+}
+
+PACKAGES =+ "totem-browser-plugin-dbg totem-browser-plugin"
+FILES_${PN} += "${datadir}/icons"
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"