summaryrefslogtreecommitdiff
path: root/packages/totem/totem_1.0.4.bb
diff options
context:
space:
mode:
authorFrederic Bompart <frederic@unknown.openembedded.org>2005-09-20 07:18:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-20 07:18:17 +0000
commitdd088063c0542a8940f201b33ae6ce904198d9ea (patch)
tree9095d086f6cb03c4db531ad6941f5b5cc61ff937 /packages/totem/totem_1.0.4.bb
parent00dc4d090496ec5391685e5c316b08c05c93448b (diff)
totem: version 1.0.2 now compiles
I removed version 0.101 which was marked as broken. A few fixes were needed to disable gnomeui code in totem-1.0.2. Don't even try to upgrade it to version 1.2.x for now: it has even more dependencies, such as a very recent version of gnome-vfs...
Diffstat (limited to 'packages/totem/totem_1.0.4.bb')
-rw-r--r--packages/totem/totem_1.0.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/totem/totem_1.0.4.bb b/packages/totem/totem_1.0.4.bb
new file mode 100644
index 0000000000..617b4aa9d0
--- /dev/null
+++ b/packages/totem/totem_1.0.4.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.gnome.org/projects/totem/"
+LICENSE="GPL"
+
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/totem/1.0/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1 \
+ file://nonautilus.patch;patch=1 \
+ file://intl.patch;patch=1 \
+ file://cflags.patch;patch=1 \
+ file://gtkonly.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libxml2"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}