summaryrefslogtreecommitdiff
path: root/packages/totem/totem_0.101.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-08-01 14:15:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-01 14:15:54 +0000
commit0bd6a7b89f81b97120760916bc6fad5ee5042cd2 (patch)
tree4619e6ef474f7255fc74f5d5b39f5932e1767e32 /packages/totem/totem_0.101.bb
parent34f09a6ee266d39ef86c438fcb0cbad0faabc36f (diff)
added totem 0.101 - BROKEN due to lack of 'libnautilus-burn' package (or option to disable it)
Diffstat (limited to 'packages/totem/totem_0.101.bb')
-rw-r--r--packages/totem/totem_0.101.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/totem/totem_0.101.bb b/packages/totem/totem_0.101.bb
new file mode 100644
index 0000000000..e78ce09043
--- /dev/null
+++ b/packages/totem/totem_0.101.bb
@@ -0,0 +1,34 @@
+BROKEN = "1"
+# do_configure() broken with:
+# No package 'libnautilus-burn' found
+
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.hadess.net/totem.php3"
+LICENSE="GPL"
+
+SRC_URI="http://www.hadess.net/files/software/totem/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine libgnomeui"
+RDEPENDS += " libgnomeui"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}