summaryrefslogtreecommitdiff
path: root/packages/toscoterm
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-01-13 11:55:49 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-13 12:09:24 -0200
commit4f6885d5470608ffeb78b491cefdf05a8f191fe0 (patch)
tree975e3279c184a77dc40398f11d9b779d8a6e8fcd /packages/toscoterm
parentefdb0d648393b6d8cedf55c1ec30c929119234ef (diff)
toscoterm: fix building with latest git version
It was failing to find gtk and to install the binary, making it unavailable for the rootfs creation.
Diffstat (limited to 'packages/toscoterm')
-rw-r--r--packages/toscoterm/toscoterm_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/packages/toscoterm/toscoterm_git.bb b/packages/toscoterm/toscoterm_git.bb
index fd9181d0a0..9826c9e9d1 100644
--- a/packages/toscoterm/toscoterm_git.bb
+++ b/packages/toscoterm/toscoterm_git.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv3"
DEPENDS = "vte"
HOMEPAGE = "https://projetos.ossystems.com.br/projects/show/toscoterm"
PV = "0.0+gitr${SRCREV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "git://projetos.ossystems.com.br/git/toscoterm.git;protocol=git"
S = "${WORKDIR}/git"
@@ -12,6 +12,10 @@ S = "${WORKDIR}/git"
do_compile() {
oe_runmake \
CC="${CC}" \
- CFLAGS="${CFLAGS} `pkg-config --cflags gtk-2.0` `pkg-config --cflags vte`" \
+ CFLAGS="${CFLAGS} `pkg-config --cflags gtk+-2.0` `pkg-config --cflags vte`" \
LDFLAGS="${LDFLAGS} `pkg-config --libs gtk+-2.0` `pkg-config --libs vte`"
}
+
+do_install() {
+ oe_runmake PREFIX="/usr" DESTDIR="${D}" install
+}