summaryrefslogtreecommitdiff
path: root/packages/tin/tin_1.9.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-08-19 17:34:42 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-08-19 17:34:42 +0000
commit75470578abf41b1632fb7f6f8afac646f438b82f (patch)
tree887b768caeac0cb1ea0a074c860ec1be3c7b6bcf /packages/tin/tin_1.9.1.bb
parent74548169592daa787b2813602acfc624aa8d4828 (diff)
tin: add 1.9.1, uses our libpcre now, no more patches necessary
Diffstat (limited to 'packages/tin/tin_1.9.1.bb')
-rw-r--r--packages/tin/tin_1.9.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/tin/tin_1.9.1.bb b/packages/tin/tin_1.9.1.bb
new file mode 100644
index 0000000000..560184f413
--- /dev/null
+++ b/packages/tin/tin_1.9.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Tin is a powerful text mode news reader."
+SECTION = "console/network"
+DEPENDS = "ncurses pcre"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.tin.org/pub/news/clients/tin/unstable/tin-${PV}.tar.gz \
+ file://m4.patch;patch=1"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+EXTRA_OECONF = "--with-screen=ncurses --with-pcre=${STAGING_LIBDIR}/.."
+
+export BUILD_CFLAGS += "-I${S}/include -DHAVE_CONFIG_H"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ cd src && oe_runmake
+}