summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2009-02-16 10:03:32 -0500
committerCliff Brake <cbrake@bec-systems.com>2009-02-16 10:03:32 -0500
commitd512927cbf42dc9a3302ecac790a18d397ea012f (patch)
tree2d624d29a763e5f9ae9b618148cfc6063e6cd50e /packages/tasks
parent68e1ea7aeddc4f7efc621558dfd424cd2fe22674 (diff)
parent3fe1150b7afa91ee59dfa6346c1f7387638b7817 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-base.bb15
-rw-r--r--packages/tasks/task-boot.bb2
-rw-r--r--packages/tasks/task-openmoko-feed.bb5
-rw-r--r--packages/tasks/task-slugos-toolchain-target.bb32
4 files changed, 47 insertions, 7 deletions
diff --git a/packages/tasks/task-base.bb b/packages/tasks/task-base.bb
index 504332f9a5..c60ae4ff0b 100644
--- a/packages/tasks/task-base.bb
+++ b/packages/tasks/task-base.bb
@@ -61,6 +61,15 @@ HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24", "linux-hotplug",""
DISTRO_SSH_DAEMON ?= "dropbear"
#
+# bluetooth manager
+#
+DISTRO_BLUETOOTH_MANAGER ?= "\
+ blueprobe \
+ bluez-utils \
+ bluez-utils-compat \
+ "
+
+#
# pcmciautils for >= 2.6.13-rc1, pcmcia-cs for others
#
PCMCIA_MANAGER ?= "${@base_contains('MACHINE_FEATURES', 'kernel26','pcmciautils','pcmcia-cs',d)} "
@@ -234,10 +243,8 @@ task-base-pcmcia26 = "\
# Provide bluez-utils-compat utils for the time being, the binaries in that package will vanish soon from upstream releases, so beware!
-RDEPENDS_task-base-bluetooth = "\
- blueprobe \
- bluez-utils \
- bluez-utils-compat \
+RDEPENDS_task-base-bluetooth = "\
+ ${DISTRO_BLUETOOTH_MANAGER} \
"
RRECOMMENDS_task-base-bluetooth = "\
diff --git a/packages/tasks/task-boot.bb b/packages/tasks/task-boot.bb
index 3d69256e64..1a74f15ad1 100644
--- a/packages/tasks/task-boot.bb
+++ b/packages/tasks/task-boot.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Basic task to get a device booting"
-PR = "r47"
+PR = "r48"
inherit task
diff --git a/packages/tasks/task-openmoko-feed.bb b/packages/tasks/task-openmoko-feed.bb
index 97807cc279..9a9e385cfa 100644
--- a/packages/tasks/task-openmoko-feed.bb
+++ b/packages/tasks/task-openmoko-feed.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Openmoko: Misc. Feed Items"
SECTION = "openmoko/base"
LICENSE = "MIT"
-PR = "r60"
+PR = "r61"
inherit task
@@ -29,7 +29,8 @@ RDEPENDS_task-openmoko-feed = "\
ntpclient ntp \
openssh openssh-scp openssh-ssh openssh-sshd openssh-sftp openssh-misc \
python python-pygtk python-pyserial python-gst python-pygame \
- python-lightblue python-pybluez \
+# python-lightblue \
+ python-pybluez \
obexpush \
ruby \
libsdl-x11 libsdl-mixer libsdl-net libsdl-ttf \
diff --git a/packages/tasks/task-slugos-toolchain-target.bb b/packages/tasks/task-slugos-toolchain-target.bb
new file mode 100644
index 0000000000..489a41213b
--- /dev/null
+++ b/packages/tasks/task-slugos-toolchain-target.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Packages for a standalone SDK or external toolchain"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+PR = "r1"
+
+PACKAGES = "${PN}"
+
+# Stuff contained in this SDK is largely taken from task-sdk-base.bb.
+# This is a starting point, and nothing more at present -- please fill
+# this out with a reasonable set of development tools for a SlugOS image.
+# Also feel free to remove stuff that's silly.
+
+RDEPENDS_${PN} = "\
+ libgcc \
+ linux-libc-headers-dev \
+ libssl \
+ libcrypto \
+ openssl-dev \
+ libstdc++ \
+ "
+
+# Not sure if we need these or not...
+NOT_SURE_ABOUT = "\
+ libsegfault \
+ "
+
+# This one needs further investigation; seems to be some sort
+# of naming problem that breaks the SDK when it is added directly.
+ODDLY_BROKEN_PACKAGES ="\
+ libz-dev \
+ "