summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-03-09 13:04:12 +0000
committerRod Whitby <rod@whitby.id.au>2007-03-09 13:04:12 +0000
commit8ec2dfcbbe96359626e2192562dd1d5aa62905b0 (patch)
tree163f53922d85cbe14545e1e5333035a3a692b07d /packages/tasks
parentc798da58f844f145cfd8604ef7784b06c6cde8bf (diff)
task-mokogateway: Initial task for an OpenMoko companion server. Designed to fit in flash on an NSLU2, or on larger devices with more flash. Will need to be updated after task-base rewrite is committed.
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-mokogateway.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/packages/tasks/task-mokogateway.bb b/packages/tasks/task-mokogateway.bb
new file mode 100644
index 0000000000..690cb48ffd
--- /dev/null
+++ b/packages/tasks/task-mokogateway.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "MokoGateway: Tasks for a companion server for the OpenMoko Linux Distribution"
+ALLOW_EMPTY = "1"
+PACKAGE_ARCH = "all"
+LICENSE = "MIT"
+PROVIDES = "task-mokogateway-everything"
+
+PACKAGES = "\
+ task-mokogateway-everything \
+ ${BASE_PACKAGES} \
+"
+
+BASE_PACKAGES = "\
+ task-mokogateway-base \
+ task-mokogateway-usbnet \
+ task-mokogateway-bluetooth \
+ task-mokogateway-wifi \
+"
+
+RDEPENDS_task-mokogateway-everything = "${BASE_PACKAGES}"
+
+DESCRIPTION_task-mokogateway-base = "MokoGateway: Base"
+RDEPENDS_task-mokogateway-base = "\
+ task-base \
+"
+
+DESCRIPTION_task-mokogateway-usbnet = "MokoGateway: USB Networking"
+RDEPENDS_task-mokogateway-usbnet = "\
+"
+RRECOMMENDS_task-mokogateway-usbnet = "\
+ kernel-module-usbnet \
+ kernel-module-cdc-ether \
+"
+
+DESCRIPTION_task-mokogateway-bluetooth = "MokoGateway: Bluetooth"
+RDEPENDS_task-mokogateway-bluetooth = "\
+ bluez-utils \
+"
+RRECOMMENDS_task-mokogateway-bluetooth = "\
+ kernel-module-bluetooth \
+ kernel-module-l2cap \
+ kernel-module-rfcomm \
+ kernel-module-hci-vhci \
+ kernel-module-bnep \
+ kernel-module-hidp \
+ kernel-module-hci-uart \
+ kernel-module-sco \
+ ${@base_contains("COMBINED_FEATURES", "usbhost", "kernel-module-hci-usb", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "kernel-module-bluetooth3c-cs", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "kernel-module-bluecard-cs", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "kernel-module-bluetoothuart-cs", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "kernel-module-dtl1-cs", "",d)} \
+"
+
+DESCRIPTION_task-mokogateway-wifi = "MokoGateway: WiFi"
+RDEPENDS_task-mokogateway-wifi = "\
+ wireless-tools \
+ ${@base_contains("COMBINED_FEATURES", "pcmcia", "hostap-utils", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "pci", "hostap-utils", "",d)} \
+ wpa-supplicant \
+"
+RRECOMMENDS_task-mokogateway-wifi = "\
+ kernel-module-ieee80211-crypt \
+ kernel-module-ieee80211-crypt-ccmp \
+ kernel-module-ieee80211-crypt-tkip \
+ kernel-module-ieee80211-crypt-wep \
+ kernel-module-arc4 \
+ kernel-module-michael-mic \
+ kernel-module-aes \
+ ${@base_contains("COMBINED_FEATURES", "usbhost", "kernel-module-zd1211rw", "",d)} \
+"
+