summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2008-10-19 00:43:17 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2008-10-19 00:43:17 +0200
commit14bf8220ea36950431c7d521a9ab47dace33ba9d (patch)
tree04a23c0f7bbea0d4142747143f355e256aaa1055 /packages/tasks
parent310ccc10715067a20f96c87c4e78553193060c90 (diff)
parentf5908addf3671abab19e1e43763b3b0ca60a451b (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-fso-compliance.bb16
-rw-r--r--packages/tasks/task-x11-illume.bb2
-rw-r--r--packages/tasks/task-x11.bb2
-rw-r--r--packages/tasks/task-xfce-base.bb29
4 files changed, 42 insertions, 7 deletions
diff --git a/packages/tasks/task-fso-compliance.bb b/packages/tasks/task-fso-compliance.bb
new file mode 100644
index 0000000000..c331d7a8d0
--- /dev/null
+++ b/packages/tasks/task-fso-compliance.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The freesmartphone.org framework -- install this task to make your distribution FSO-compliant."
+SECTION = "fso/base"
+LICENSE = "MIT"
+PV = "1.0"
+FILE_PR = "r0"
+
+inherit task
+
+RDEPENDS_${PN} = "\
+ frameworkd \
+ fso-gpsd \
+"
+
+RRECOMMENDS_${PN} = "\
+ gsm0710muxd \
+"
diff --git a/packages/tasks/task-x11-illume.bb b/packages/tasks/task-x11-illume.bb
index a477c6e8c5..b84efec516 100644
--- a/packages/tasks/task-x11-illume.bb
+++ b/packages/tasks/task-x11-illume.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The Illume Windowing Environment -- install this task to get the
SECTION = "x11/wm"
LICENSE = "MIT"
PV = "1.0"
-PR = "r0"
+FILE_PR = "r0"
# WORK IN PROGRESS
diff --git a/packages/tasks/task-x11.bb b/packages/tasks/task-x11.bb
index ad5ca3a412..ce1fa79bba 100644
--- a/packages/tasks/task-x11.bb
+++ b/packages/tasks/task-x11.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The X Window System -- install this task to get a client/server b
SECTION = "x11/server"
LICENSE = "MIT"
PV = "1.0"
-PR = "r0"
+FILE_PR = "r0"
# WORK IN PROGRESS
diff --git a/packages/tasks/task-xfce-base.bb b/packages/tasks/task-xfce-base.bb
index bf6813a4ef..b734341c54 100644
--- a/packages/tasks/task-xfce-base.bb
+++ b/packages/tasks/task-xfce-base.bb
@@ -4,12 +4,31 @@
DESCRIPTION = "All packages required for an base XFCE installation"
LICENSE = "MIT"
-FILE_PR = "r3"
+FILE_PR = "r4"
inherit task
-RDEPENDS_${PN} = "xfce-mcs-manager xfwm4 xfwm4-theme-default xfce-utils xfdesktop \
- xfce4-panel xfce4-panel-plugins xfce-mcs-plugins xfwm4-mcs-plugins \
- xfce4-panel-mcs-plugins \
- xfdesktop-mcs-plugins"
+RDEPENDS_${PN} = " \
+ xfce-mcs-manager \
+ xfwm4 \
+ xfwm4-theme-default \
+ xfce-utils \
+ xfdesktop \
+ xfce4-panel \
+ xfce4-panel-plugin-actions \
+ xfce4-panel-plugin-clock \
+ xfce4-panel-plugin-iconbox \
+ xfce4-panel-plugin-launcher \
+ xfce4-panel-plugin-pager \
+ xfce4-panel-plugin-separator \
+ xfce4-panel-plugin-showdesktop \
+ xfce4-panel-plugin-systray \
+ xfce4-panel-plugin-tasklist \
+ xfce4-panel-plugin-windowlist \
+ xfce-mcs-plugins \
+ xfwm4-mcs-plugins \
+ xfce4-panel-mcs-plugins \
+ xfdesktop-mcs-plugins \
+"
+
RRECOMMENDS_${PN} = "xfce-utils-mcs-plugins"