summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-09-04 11:46:23 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-09-04 11:46:23 +0000
commite473727021ff71922845c13e669ca30d6b7a2ed8 (patch)
tree3c56cb13f2bddccd3c477a78035bc23436be079f /packages/tasks
parent692d506dce36f616e2493136ea43e3b00c66e884 (diff)
parentadc0e34177df635be3bec485a184e5573f13383e (diff)
merge of '2f0f9f2cfcb50cad0cf024eca65c522c764fe3cf'
and '3fed235384e32b1c9ba26c86ff39b2ffb928fbed'
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-openmoko-feed.bb16
-rw-r--r--packages/tasks/task-openmoko.bb15
2 files changed, 27 insertions, 4 deletions
diff --git a/packages/tasks/task-openmoko-feed.bb b/packages/tasks/task-openmoko-feed.bb
index 45e6f1b46c..f3e3ee8456 100644
--- a/packages/tasks/task-openmoko-feed.bb
+++ b/packages/tasks/task-openmoko-feed.bb
@@ -1,15 +1,27 @@
DESCRIPTION = "OpenMoko: Misc. Feed Items"
SECTION = "openmoko/base"
LICENSE = "MIT"
-PR = "r4"
+PR = "r8"
inherit task
RDEPENDS_task-openmoko-feed = "\
- ntpclient \
+ aspell enchant \
+ bluez-hcidump \
+ gpe-filemanager gpe-gallery gpe-timesheet gpe-todo \
+ ipkg-link \
+ kbdd \
+ midori \
+ mtpaint \
+ mysql \
+ nano \
+ ntpclient ntp \
openssh openssh-scp openssh-ssh openssh-sshd openssh-sftp openssh-misc \
python \
python-pygtk \
python-pyserial \
+ ruby \
timezones \
+ tor \
+ vnc \
"
diff --git a/packages/tasks/task-openmoko.bb b/packages/tasks/task-openmoko.bb
index 3616d843e2..0ddf590c9d 100644
--- a/packages/tasks/task-openmoko.bb
+++ b/packages/tasks/task-openmoko.bb
@@ -68,14 +68,25 @@ RDEPENDS_task-openmoko-ui = "\
settings-daemon \
\
openmoko-session2 \
- openmoko-theme-standard2 \
- openmoko-icon-theme-standard2 \
openmoko-sound-system \
openmoko-sound-theme-standard \
neod \
gpe-scap \
"
+# handle theming. FIXME: properly use machine database in a smart way,
+# taking into account not only size but also PPI! Ultimately this might
+# need recomputing some theme files and images on-the-fly :/ SVG and logical
+# theme description anyone? Or simply Edje to the rescue! :D
+THEMES = "openmoko-icon-theme-standard2 openmoko-theme-standard2"
+THEMES_a780 = "openmoko-icon-theme-standard2 openmoko-theme-standard2-qvga"
+THEMES_e680 = "openmoko-icon-theme-standard2 openmoko-theme-standard2-qvga"
+THEMES_a1200 = "openmoko-icon-theme-standard2 openmoko-theme-standard2-qvga"
+THEMES_rokre2 = "openmoko-icon-theme-standard2 openmoko-theme-standard2-qvga"
+THEMES_rokre6 = "openmoko-icon-theme-standard2 openmoko-theme-standard2-qvga"
+
+RDEPENDS_task-openmoko-ui += "${THEMES}"
+
#
# task-openmoko-base
#