summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-10-15 21:33:01 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-10-16 14:26:17 +0200
commit7cc414eef30f9c44e5aa02c7cd0694b87971a53b (patch)
treeb44e6d0c512df8e9736c4473972784141fea9a1a /packages/tasks
parent772e59441bb0a133b9412eb9deacf817a6eb1b8c (diff)
add task-x11 and task-x11-illume
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-x11-illume.bb27
-rw-r--r--packages/tasks/task-x11.bb36
2 files changed, 63 insertions, 0 deletions
diff --git a/packages/tasks/task-x11-illume.bb b/packages/tasks/task-x11-illume.bb
new file mode 100644
index 0000000000..a477c6e8c5
--- /dev/null
+++ b/packages/tasks/task-x11-illume.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "The Illume Windowing Environment -- install this task to get the Enlightenment Window Manager + the Illume environment."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r0"
+
+# WORK IN PROGRESS
+
+inherit task
+
+# Default illume theme
+ILLUME_THEME ?= "illume-theme-illume"
+
+RDEPENDS_${PN} = "\
+ task-x11-server \
+ task-x11-utils \
+# xserver-kdrive-splash-illume \
+ \
+ e-wm \
+ illume \
+ illume-config-illume \
+ illume-dicts-english-us \
+ illume-keyboards-default \
+ illume-keyboards-numbers \
+ illume-keyboards-terminal \
+ ${ILLUME_THEME} \
+"
diff --git a/packages/tasks/task-x11.bb b/packages/tasks/task-x11.bb
new file mode 100644
index 0000000000..ad5ca3a412
--- /dev/null
+++ b/packages/tasks/task-x11.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
+SECTION = "x11/server"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r0"
+
+# WORK IN PROGRESS
+
+inherit task
+
+PACKAGES += "\
+ ${PN}-server \
+ ${PN}-utils \
+"
+
+RRECOMMENDS_${PN} = "\
+ ${PN}-server \
+ ${PN}-utils \
+"
+
+# Some machines don't set a *runtime* provider for X, so default to Xfbdev here
+# virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
+XSERVER ?= "xserver-kdrive-fbdev"
+
+RDEPENDS_${PN}-server = "\
+ ${XSERVER} \
+"
+
+RDEPENDS_${PN}-utils = "\
+ xserver-kdrive-common \
+ xserver-nodm-init \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+"