summaryrefslogtreecommitdiff
path: root/packages/sysvinit
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-15 18:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-15 18:40:08 +0000
commite9c2824399fc3d1354ab2d5e785e5fb2b1e2e30b (patch)
treee48b1ba574849f964ea8cd263e8c8dcde77d83ae /packages/sysvinit
parent224c297360b45448456d2132dffa7de007047dc0 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/15 17:18:15+00:00 rpsys.net!RP openzaurus-2.6: corgi: fix backlight race, update mmc/sd support, start led support 2005/01/15 17:38:34+01:00 vanille.de!mickeyl add init progress reporting capabilities to rcS. to get progress reporting, apply the elpp patch to your kernel and set VERBOSE=progress in /etc/default/rcS. BKrev: 41e96388xiGAOrYA-5Qo4SaYygQwkA
Diffstat (limited to 'packages/sysvinit')
-rw-r--r--packages/sysvinit/sysvinit/rcS98
-rw-r--r--packages/sysvinit/sysvinit_2.86.bb5
2 files changed, 100 insertions, 3 deletions
diff --git a/packages/sysvinit/sysvinit/rcS b/packages/sysvinit/sysvinit/rcS
index e69de29bb2..c011b0d4f4 100644
--- a/packages/sysvinit/sysvinit/rcS
+++ b/packages/sysvinit/sysvinit/rcS
@@ -0,0 +1,98 @@
+#!/bin/sh
+#
+# rcS Call all S??* scripts in /etc/rcS.d in
+# numerical/alphabetical order.
+#
+# Version: @(#)/etc/init.d/rcS 2.76 19-Apr-1999 miquels@cistron.nl
+#
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+runlevel=S
+prevlevel=N
+umask 022
+export PATH runlevel prevlevel
+
+#
+# See if system needs to be setup. This is ONLY meant to
+# be used for the initial setup after a fresh installation!
+#
+if [ -x /sbin/unconfigured.sh ]
+then
+ /sbin/unconfigured.sh
+fi
+
+#
+# Source defaults.
+#
+. /etc/default/rcS
+
+#
+# Trap CTRL-C &c only in this shell so we can interrupt subprocesses.
+#
+trap ":" INT QUIT TSTP
+
+#
+# Do we have /proc/progress and want to have a progress display?
+# If so, calculate the number of scripts and the increasing step
+#
+if [ "$VERBOSE" = progress ]; then
+ mount /proc
+ if [ ! -e /proc/progress ]; then
+ echo "INIT: VERBOSE=progress requested, but /proc/progress not available."
+ echo "INIT: Falling back to VERBOSE=no"
+ VERBOSE=no
+ else
+ set `ls -1 /etc/rc$runlevel.d/S* | wc`
+ numscripts=$1
+ PROGRESS_incstep=`expr 70 / $1`
+ PROGRESS_value=30
+ export PROGRESS_value PROGRESS_incstep
+ fi
+fi
+export VERBOSE
+
+#
+# Call all parts in order.
+#
+for i in /etc/rcS.d/S??*
+do
+ # Ignore dangling symlinks for now.
+ [ ! -f "$i" ] && continue
+
+ # Handle verbosity
+ [ "$VERBOSE" = very ] && echo "INIT: Running $i..."
+ if [ "$VERBOSE" = progress ]; then
+ export PROGRESS_value=`expr $PROGRESS_value + $PROGRESS_incstep`
+ echo "$PROGRESS_value Starting $i..." >/proc/progress
+ fi
+
+ case "$i" in
+ *.sh)
+ # Source shell script for speed.
+ (
+ trap - INT QUIT TSTP
+ set start
+ . $i
+ )
+ ;;
+ *)
+ # No sh extension, so fork subprocess.
+ $i start
+ ;;
+ esac
+done
+
+#
+# For compatibility, run the files in /etc/rc.boot too.
+#
+[ -d /etc/rc.boot ] && run-parts /etc/rc.boot
+
+#
+# Finish setup if needed. The comment above about
+# /sbin/unconfigured.sh applies here as well!
+#
+if [ -x /sbin/setup.sh ]
+then
+ /sbin/setup.sh
+fi
+
diff --git a/packages/sysvinit/sysvinit_2.86.bb b/packages/sysvinit/sysvinit_2.86.bb
index 2131e3c41e..12b16eda56 100644
--- a/packages/sysvinit/sysvinit_2.86.bb
+++ b/packages/sysvinit/sysvinit_2.86.bb
@@ -1,10 +1,9 @@
-SECTION = "base"
DESCRIPTION = "System-V like init."
+SECTION = "base"
LICENSE = "GPL"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
-
-PR = "r5"
+PR = "r7"
# USE_VT and SERIAL_CONSOLE are generally defined by the MACHINE .conf.
# Set PACKAGE_ARCH appropriately.