summaryrefslogtreecommitdiff
path: root/packages/syslinux
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-01-16 13:43:50 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-01-22 18:51:09 -0200
commitd8e12feec852f733e4d1d67c3de3b7dc8deec282 (patch)
treecb388a4fab801a2bb4ab4c7a5ec8d69468f63cc8 /packages/syslinux
parentf01e6cb9955e8a7304abf8b391ed97385eacdb3b (diff)
syslinux: add a non-native package
Diffstat (limited to 'packages/syslinux')
-rw-r--r--packages/syslinux/syslinux-native_3.63.bb19
-rw-r--r--packages/syslinux/syslinux_3.63.bb32
2 files changed, 34 insertions, 17 deletions
diff --git a/packages/syslinux/syslinux-native_3.63.bb b/packages/syslinux/syslinux-native_3.63.bb
index 471ef1bc8f..3cd1ff8da0 100644
--- a/packages/syslinux/syslinux-native_3.63.bb
+++ b/packages/syslinux/syslinux-native_3.63.bb
@@ -1,20 +1,9 @@
# syslinux-native OE build file
# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Copyright (C) 2009, O.S. Systems Software Ltda. All Rights Reserved
# Released under the MIT license (see packages/COPYING)
-DESCRIPTION="A multi-purpose linux bootloader"
-HOMEPAGE="http://syslinux.zytor.com/"
-LICENSE="GPL"
-PR="r1"
-
-# If you really want to run syslinux, you need mtools. We just want the
-# ldlinux.* stuff for now, so skip mtools-native
-DEPENDS="nasm-native"
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
-
-S="${WORKDIR}/syslinux-${PV}"
-
+require syslinux_${PV}.bb
inherit native
STAGE_TEMP="${WORKDIR}/stage_temp"
@@ -27,10 +16,6 @@ do_stage() {
install -m 755 ${STAGE_TEMP}/usr/bin/syslinux ${STAGING_BINDIR}
install -m 755 ${STAGE_TEMP}/sbin/extlinux ${STAGING_BINDIR}
- # When building media, the syslinux binary isn't nearly as useful
- # as the DOS data files, so we copy those into a special location
- # for usage during a image build stage
-
install -d ${STAGING_DATADIR}/syslinux
install -m 0644 ${STAGE_TEMP}/usr/lib/syslinux/isolinux.bin ${STAGING_DATADIR}/syslinux/isolinux.bin
install -m 644 ${S}/ldlinux.sys ${STAGING_DATADIR}/syslinux/ldlinux.sys
diff --git a/packages/syslinux/syslinux_3.63.bb b/packages/syslinux/syslinux_3.63.bb
new file mode 100644
index 0000000000..95fb55708a
--- /dev/null
+++ b/packages/syslinux/syslinux_3.63.bb
@@ -0,0 +1,32 @@
+# syslinux OE build file
+# Copyright (C) 2009, O.S. Systems Software Ltda. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A multi-purpose linux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+LICENSE="GPL"
+DEPENDS="nasm-native"
+RDEPENDS="mtools"
+PR="r2"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/boot/syslinux/syslinux-${PV}.tar.bz2 "
+
+S="${WORKDIR}/syslinux-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ # drop win32 targets or build fails
+ sed -i 's,win32/\S*,,g' -i Makefile
+}
+
+do_compile() {
+ oe_runmake CC="${CC}"
+}
+
+do_install() {
+ oe_runmake install INSTALLROOT="${D}"
+
+ # we don't use com32, drop it
+ rm -r "${D}/${libdir}/syslinux/com32"
+}