summaryrefslogtreecommitdiff
path: root/packages/sylpheed/sylpheed_2.2.9.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-10-20 11:55:16 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-10-20 11:55:16 +0000
commit0f03543eb2a001204993d7c22920feda3748fb31 (patch)
tree849557f9525515c2a5673ef617fd088f4d9c49c4 /packages/sylpheed/sylpheed_2.2.9.bb
parent21ccc08d57430f14dcfa9b85ffb52437c2361099 (diff)
parenta81633e35bf595208cf9f6631b460eb17d56bab4 (diff)
merge of '296ff29bfd956e25378dc4b3d757bfe71b1010d5'
and '9a74dad27351d4893343978ef329c84a1fc7dbfb'
Diffstat (limited to 'packages/sylpheed/sylpheed_2.2.9.bb')
-rw-r--r--packages/sylpheed/sylpheed_2.2.9.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_2.2.9.bb b/packages/sylpheed/sylpheed_2.2.9.bb
new file mode 100644
index 0000000000..6223624fc5
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.2.9.bb
@@ -0,0 +1,32 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.2/sylpheed-${PV}.tar.bz2 \
+ file://sylpheed-2.2.2-libsylph-Makefile-am.patch;patch=1 \
+ file://sylpheed-2.2.2-src-Makefile-am.patch;patch=1 \
+ file://sylpheed-gnutls_2.2.4.patch;patch=1"
+
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--disable-ssl --enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+