summaryrefslogtreecommitdiff
path: root/packages/sylpheed/sylpheed_2.0.0rc.bb
diff options
context:
space:
mode:
authorPatrick Steiner <law@a1.net>2005-07-24 18:59:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-24 18:59:29 +0000
commita9c5cdd88e2ea2eb3d4a880ea0124bcc908b2b27 (patch)
tree1ddc359a4ba33c1303ce045d205b9498657d6d8a /packages/sylpheed/sylpheed_2.0.0rc.bb
parent6af976abd7164a5471fa7e36fd4f598b8f96d4a4 (diff)
added sylpheed2.0.0rc bb and patch file
Diffstat (limited to 'packages/sylpheed/sylpheed_2.0.0rc.bb')
-rw-r--r--packages/sylpheed/sylpheed_2.0.0rc.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_2.0.0rc.bb b/packages/sylpheed/sylpheed_2.0.0rc.bb
new file mode 100644
index 0000000000..531d694f98
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.0.0rc.bb
@@ -0,0 +1,32 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Patrick Steiner <patrick.steiner@a1.net>"
+LICENSE = "GPL"
+PR = "r3"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.0beta/sylpheed-2.0.0rc.tar.bz2 \
+ file://sylpheed-gnutls_2.0.0rc.patch;patch=1 \
+ file://sylpheed-gnutls-extra.patch;patch=1 "
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+