summaryrefslogtreecommitdiff
path: root/packages/sylpheed/sylpheed_2.0.0beta6.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2005-07-21 03:28:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-21 03:28:55 +0000
commit5c8f0ac921d317857f53af063b6158fe450e3977 (patch)
tree1d419644017f9a9f2acc62908c7066806cdd078a /packages/sylpheed/sylpheed_2.0.0beta6.bb
parent106a843b00bc7003f3dcdaeca83d453b595b49c3 (diff)
parent79854f3a16e4bd18ae87450fde8061778f192585 (diff)
merge of 60b47beac72c6f1f23514b42a309716b470d471b
and a6f1ef5bbb3cac8192d0a7bc6d5c64b301e70463
Diffstat (limited to 'packages/sylpheed/sylpheed_2.0.0beta6.bb')
-rw-r--r--packages/sylpheed/sylpheed_2.0.0beta6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_2.0.0beta6.bb b/packages/sylpheed/sylpheed_2.0.0beta6.bb
new file mode 100644
index 0000000000..4fab8e8bb8
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.0.0beta6.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.0beta/sylpheed-2.0.0beta6.tar.bz2 \
+ file://sylpheed-gnutls_2.0.0beta6.patch;patch=1"
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+