summaryrefslogtreecommitdiff
path: root/packages/sylpheed/sylpheed_1.9.12.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-04 12:40:16 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-04 12:40:16 +0000
commite507c73e30a9268d76d6a9c0aa215ab45d8fa81a (patch)
tree417dba01a7f20236a51de253947e281d041b34c2 /packages/sylpheed/sylpheed_1.9.12.bb
parent7f84f3dd033aa351893bb5282816ca7e465217f2 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/04 14:37:56+02:00 dyndns.org!reenoo sylpheed: some gpgme m4 macros are necessary at configure time. thanks to pb_ for pointing this out. 2005/06/04 14:20:26+02:00 dyndns.org!reenoo sylpheed: actually enable gnutls. remove gpgme from DEPENDS for now since it's not enabled and doesn't work either ATM. 2005/06/04 14:11:46+02:00 dyndns.org!reenoo gnutls: export asn1_* functions from libgnutls.so. fixes bug #57. BKrev: 42a1a130bcszKNK9Vo8WaspfQ9KjKw
Diffstat (limited to 'packages/sylpheed/sylpheed_1.9.12.bb')
-rw-r--r--packages/sylpheed/sylpheed_1.9.12.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_1.9.12.bb b/packages/sylpheed/sylpheed_1.9.12.bb
index e69de29bb2..00da7907a7 100644
--- a/packages/sylpheed/sylpheed_1.9.12.bb
+++ b/packages/sylpheed/sylpheed_1.9.12.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v1.9/sylpheed-1.9.12.tar.bz2 \
+ file://sylpheed-gnutls.patch;patch=1"
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+