summaryrefslogtreecommitdiff
path: root/packages/sylpheed/claws-mail_3.0.2.bb
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2007-10-10 16:22:56 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-10-10 16:22:56 +0000
commitaae61e5f21fc55817e50b13c0e60651559a30ab4 (patch)
treea540fcee7d30e75c896d44d8b12b72f699786d96 /packages/sylpheed/claws-mail_3.0.2.bb
parentdd160afafc4690a857bc3421a8c5f59a768a8e89 (diff)
parent246747222a86829fad9d70855698c66b18af9285 (diff)
merge of 'a6eb93692ca38c674d1bc2d35444de89a6f5414f'
and 'ea03196e34e8a5d2435ae7d87522ec1acb271da9'
Diffstat (limited to 'packages/sylpheed/claws-mail_3.0.2.bb')
-rw-r--r--packages/sylpheed/claws-mail_3.0.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/sylpheed/claws-mail_3.0.2.bb b/packages/sylpheed/claws-mail_3.0.2.bb
new file mode 100644
index 0000000000..29e7a5bc63
--- /dev/null
+++ b/packages/sylpheed/claws-mail_3.0.2.bb
@@ -0,0 +1,43 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ libetpan openssl aspell"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2 \
+ file://desktop.patch;patch=1 \
+ "
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell-test \
+ --enable--aspell \
+ --disable-manual \
+ --disable-crash-dialog \
+ --disable-jpilot \
+ --disable-trayicon-plugin \
+ --disable-spamassassin-plugin \
+ --disable-bogofilter-plugin \
+ --disable-pgpcore-plugin \
+ --disable-pgpmime-plugin \
+ --disable-pgpinline-plugin \
+ --disable-dillo-viewer-plugin \
+ --disable-clamav-plugin \
+ --disable-gnomeprint \
+ --disable-valgrind \
+ "
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 claws-mail.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
+}
+
+do_stage () {
+ autotools_stage_all
+}
+