summaryrefslogtreecommitdiff
path: root/packages/sylpheed/claws-mail.inc
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-07-18 14:08:35 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-07-18 14:08:35 +0000
commit0772c3749d33cf0a5858f5d966ab5f2cb8a8ae7e (patch)
tree388693f9c49ed2bc60e0f210bd00ce2a5a9754c6 /packages/sylpheed/claws-mail.inc
parentb10ab4c66b5a54fac0a10df1eb59b08f5eb217b4 (diff)
claws-mail_2.9.1.bb : version bump and new embedded GUI thanks to poky
claws-plugin-* : version bumps for above, thanks to poky
Diffstat (limited to 'packages/sylpheed/claws-mail.inc')
-rw-r--r--packages/sylpheed/claws-mail.inc54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/sylpheed/claws-mail.inc b/packages/sylpheed/claws-mail.inc
new file mode 100644
index 0000000000..e62ca9036a
--- /dev/null
+++ b/packages/sylpheed/claws-mail.inc
@@ -0,0 +1,54 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ libetpan openssl aspell"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2 \
+ file://desktop.patch;patch=1 \
+ file://streamline-ui.patch;patch=1 \
+ "
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell-test \
+ --enable--aspell \
+ --disable-manual \
+ --disable-crash-dialog \
+ --disable-jpilot \
+ --disable-trayicon-plugin \
+ --disable-spamassassin-plugin \
+ --disable-bogofilter-plugin \
+ --disable-pgpcore-plugin \
+ --disable-pgpmime-plugin \
+ --disable-pgpinline-plugin \
+ --disable-dillo-viewer-plugin \
+ --disable-clamav-plugin \
+ --disable-gnomeprint \
+ --disable-valgrind \
+ "
+
+CFLAGS += "-D_GNU_SOURCE"
+
+inherit autotools pkgconfig
+
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 claws-mail.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
+ mv ${D}${bindir}/${TARGET_SYS}-claws-mail ${D}${bindir}/${PN}
+}
+
+do_stage () {
+ autotools_stage_all
+}
+