summaryrefslogtreecommitdiff
path: root/packages/swt
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-01-23 10:31:22 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2008-01-23 10:31:22 +0000
commit75c94213fe3bce68b3e787842eb65a8ff004c9ce (patch)
tree431b74e7f9630c9d33c12f1515bdf40c1a41685d /packages/swt
parent9abe95dd3d38718f0d399bcf858f35652e14400c (diff)
swt-gtk: fix dependency and possible cross compiling badness
* need classpath to build * remove -I${JAVA_HOME}/include and -I${JAVA_HOME}/include/linux because it might cause error with or without JAVA_HOME set and no extra include files are required anyway.
Diffstat (limited to 'packages/swt')
-rw-r--r--packages/swt/files/make_linux-fix.patch22
-rw-r--r--packages/swt/swt-gtk.inc2
-rw-r--r--packages/swt/swt3.4-gtk_3.3+3.4M3.bb3
3 files changed, 25 insertions, 2 deletions
diff --git a/packages/swt/files/make_linux-fix.patch b/packages/swt/files/make_linux-fix.patch
new file mode 100644
index 0000000000..1c98f5cad2
--- /dev/null
+++ b/packages/swt/files/make_linux-fix.patch
@@ -0,0 +1,22 @@
+Index: swt-source/make_linux.mak
+===================================================================
+--- swt-source.orig/make_linux.mak 2008-01-23 15:08:02.000000000 +0800
++++ swt-source/make_linux.mak 2008-01-23 15:08:21.000000000 +0800
+@@ -74,8 +74,6 @@
+ -Wno-non-virtual-dtor \
+ -fPIC \
+ -I. \
+- -I$(JAVA_HOME)/include \
+- -I$(JAVA_HOME)/include/linux \
+ ${SWT_PTR_CFLAGS}
+ MOZILLALIBS = -shared -Wl,--version-script=mozilla_exports -Bsymbolic
+ MOZILLAEXCLUDES = -DNO_XPCOMGlueShutdown -DNO_XPCOMGlueStartup
+@@ -96,8 +94,6 @@
+ -DSWT_VERSION=$(SWT_VERSION) \
+ $(NATIVE_STATS) \
+ -DLINUX -DGTK \
+- -I$(JAVA_HOME)/include \
+- -I$(JAVA_HOME)/include/linux \
+ -fPIC \
+ ${SWT_PTR_CFLAGS}
+ LIBS = -shared -fPIC
diff --git a/packages/swt/swt-gtk.inc b/packages/swt/swt-gtk.inc
index 6afadf1cab..4522e57503 100644
--- a/packages/swt/swt-gtk.inc
+++ b/packages/swt/swt-gtk.inc
@@ -3,7 +3,7 @@ LICENSE = "CPL MPL LGPL"
inherit java-library
-DEPENDS = "cairo gtk+ atk libxtst"
+DEPENDS = "cairo gtk+ atk libxtst classpath"
S = "${WORKDIR}/swt-source"
diff --git a/packages/swt/swt3.4-gtk_3.3+3.4M3.bb b/packages/swt/swt3.4-gtk_3.3+3.4M3.bb
index 5d411f1be6..701339d374 100644
--- a/packages/swt/swt3.4-gtk_3.3+3.4M3.bb
+++ b/packages/swt/swt3.4-gtk_3.3+3.4M3.bb
@@ -1,7 +1,8 @@
require swt-gtk.inc
SRC_URI = "http://ftp.wh2.tu-dresden.de/pub/mirrors/eclipse/eclipse/downloads/drops/S-3.4M3-200711012000/swt-3.4M3-gtk-linux-x86.zip \
- file://Makefile"
+ file://Makefile \
+ file://make_linux-fix.patch;patch=1"
# A number which is used by SWT to mark the shared libraries.
SWTVERSION = "3416"