summaryrefslogtreecommitdiff
path: root/packages/sword/sword_1.5.7.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/sword/sword_1.5.7.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/sword/sword_1.5.7.bb')
-rw-r--r--packages/sword/sword_1.5.7.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/sword/sword_1.5.7.bb b/packages/sword/sword_1.5.7.bb
index e69de29bb2..1c12334d37 100644
--- a/packages/sword/sword_1.5.7.bb
+++ b/packages/sword/sword_1.5.7.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r5"
+
+SRC_URI = "http://www.crosswire.org/~dglassey/sword-1.5.7a.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+ oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sword/
+ for f in include/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sword/
+ done
+
+}