summaryrefslogtreecommitdiff
path: root/packages/subversion/subversion_1.4.5.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-11-30 14:14:53 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-11-30 14:14:53 +0000
commit89ba1da42a5b7effe8653782eb7f8abfb9222dcd (patch)
treee4891c48e491928598492b1b35deb4748f104ea0 /packages/subversion/subversion_1.4.5.bb
parent37b5214d02ac06525ec6a9fa817ec8862d16eeb2 (diff)
parent22d8e49c3956522d7dba6e885c7ca04f06aea97c (diff)
merge of '3948c8054b50f67afee06a66abbab4a35915d297'
and 'cefef520b1840df3899cd9fc5a4fc3cb9faa38ce'
Diffstat (limited to 'packages/subversion/subversion_1.4.5.bb')
-rw-r--r--packages/subversion/subversion_1.4.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/subversion/subversion_1.4.5.bb b/packages/subversion/subversion_1.4.5.bb
new file mode 100644
index 0000000000..1daf45bd0c
--- /dev/null
+++ b/packages/subversion/subversion_1.4.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}