summaryrefslogtreecommitdiff
path: root/packages/subversion/subversion_1.4.5.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2007-11-29 21:52:01 +0000
committerMatthias Hentges <oe@hentges.net>2007-11-29 21:52:01 +0000
commitae7eb4076905d0b10613ba756acc9924e3d4fbaf (patch)
treed696d2ffa10fdc1f78c2639a4f3747b3b8f4bc12 /packages/subversion/subversion_1.4.5.bb
parent67a1d946c02b02f76e70e792d4cfb1b0c5ada84e (diff)
parent281e31e88a5958f8d22ade40fd7f1713a470f7c3 (diff)
merge of '19bacabe62a70bf0818d663c4cd3bc168e5cf49e'
and '332e97250454514e2c07aea9f1695ab21166d191'
Diffstat (limited to 'packages/subversion/subversion_1.4.5.bb')
-rw-r--r--packages/subversion/subversion_1.4.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/subversion/subversion_1.4.5.bb b/packages/subversion/subversion_1.4.5.bb
new file mode 100644
index 0000000000..1daf45bd0c
--- /dev/null
+++ b/packages/subversion/subversion_1.4.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}