summaryrefslogtreecommitdiff
path: root/packages/subversion/subversion_1.4.5.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-11-30 11:41:06 +0000
committerRod Whitby <rod@whitby.id.au>2007-11-30 11:41:06 +0000
commit762e232f884a306456ff24b65061ba2c87728413 (patch)
tree41eb5cc03456a89e9b2310fc5d0f5e530743ec79 /packages/subversion/subversion_1.4.5.bb
parent6b1fd5f198553ce441cfe7bb8b94eff1226874b6 (diff)
parent39565118303f565d78a6b5429eafdbad99ee6351 (diff)
merge of '0a81de11f045dd65f6ea4c630250337cc8f718b2'
and '0dbb48946ab15c0ee9c232d1a1fc31e5b65037cd'
Diffstat (limited to 'packages/subversion/subversion_1.4.5.bb')
-rw-r--r--packages/subversion/subversion_1.4.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/subversion/subversion_1.4.5.bb b/packages/subversion/subversion_1.4.5.bb
new file mode 100644
index 0000000000..1daf45bd0c
--- /dev/null
+++ b/packages/subversion/subversion_1.4.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}