summaryrefslogtreecommitdiff
path: root/packages/squid/squid_2.6.STABLE14.bb
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-03-26 14:18:00 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-03-26 14:18:00 +0000
commit4c87a2194276a51024de7a1aa15bada9798687cf (patch)
tree5f745438b9efc548f4c3ef1717bba2cfae500026 /packages/squid/squid_2.6.STABLE14.bb
parentc86759af98a513b368c047195d2a923164f98c25 (diff)
squid: improve configuration defaults and provide init script
* provide sane defaults for configuration file (based on Debian package) * provide an init script for squid which creates log/cache directories as needed
Diffstat (limited to 'packages/squid/squid_2.6.STABLE14.bb')
-rw-r--r--packages/squid/squid_2.6.STABLE14.bb24
1 files changed, 21 insertions, 3 deletions
diff --git a/packages/squid/squid_2.6.STABLE14.bb b/packages/squid/squid_2.6.STABLE14.bb
index beef3ba2b0..10c20c505e 100644
--- a/packages/squid/squid_2.6.STABLE14.bb
+++ b/packages/squid/squid_2.6.STABLE14.bb
@@ -1,18 +1,36 @@
DESCRIPTION = "Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more"
LICENSE = "GPLv2"
-
+PR = "r1"
DEPENDS = "squid-native-${PV}"
-SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-${PV}.tar.bz2"
+SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-${PV}.tar.bz2 \
+ file://fix_epoll_check.patch;patch=1 \
+ file://squid.init"
-inherit autotools
+inherit autotools update-rc.d
EXTRA_OECONF = "--disable-epoll --disable-nls"
+logdir = ${localstatedir}/log/squid
+EXTRA_OEMAKE = "\
+ DEFAULT_CACHE_LOG=${logdir}/cache.log \
+ DEFAULT_ACCESS_LOG=${logdir}/access.log \
+ DEFAULT_STORE_LOG=${logdir}/store.log \
+ DEFAULT_PID_FILE=${localstatedir}/run/squid.pid \
+ DEFAULT_SWAP_DIR=${localstatedir}/spool/squid \
+ "
+
+INITSCRIPT_NAME = "squid"
+
do_configure_append() {
sed -i -e 's|./cf_gen |${STAGING_BINDIR_NATIVE}/cf_gen |g' src/Makefile
}
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/squid.init ${D}${sysconfdir}/init.d/squid
+}
+
# this packages the languages better and saves some space, installs
# English as errors default and the others in locale package