summaryrefslogtreecommitdiff
path: root/packages/squid/squid_2.6.STABLE14.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-03-26 18:46:06 +0000
committerKoen Kooi <koen@openembedded.org>2008-03-26 18:46:06 +0000
commit48fd147498115e7682153b9ec28f4ab0065a845e (patch)
tree86b0d7876538f6c5f2e73a82020864ac10e9d020 /packages/squid/squid_2.6.STABLE14.bb
parentf76280c3bdee25e5126d68f3891bb240b3cd1ce9 (diff)
parentf7147e250bbe3dfc84913aa7a16d58026d98ae90 (diff)
merge of '1ba445dfd1a9b934962a4db388d6ab641b3f74e8'
and '8f2da0702f522e178a88e3c2dd8f65e05d0680a7'
Diffstat (limited to 'packages/squid/squid_2.6.STABLE14.bb')
-rw-r--r--packages/squid/squid_2.6.STABLE14.bb24
1 files changed, 21 insertions, 3 deletions
diff --git a/packages/squid/squid_2.6.STABLE14.bb b/packages/squid/squid_2.6.STABLE14.bb
index beef3ba2b0..10c20c505e 100644
--- a/packages/squid/squid_2.6.STABLE14.bb
+++ b/packages/squid/squid_2.6.STABLE14.bb
@@ -1,18 +1,36 @@
DESCRIPTION = "Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more"
LICENSE = "GPLv2"
-
+PR = "r1"
DEPENDS = "squid-native-${PV}"
-SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-${PV}.tar.bz2"
+SRC_URI = "http://www.squid-cache.org/Versions/v2/2.6/squid-${PV}.tar.bz2 \
+ file://fix_epoll_check.patch;patch=1 \
+ file://squid.init"
-inherit autotools
+inherit autotools update-rc.d
EXTRA_OECONF = "--disable-epoll --disable-nls"
+logdir = ${localstatedir}/log/squid
+EXTRA_OEMAKE = "\
+ DEFAULT_CACHE_LOG=${logdir}/cache.log \
+ DEFAULT_ACCESS_LOG=${logdir}/access.log \
+ DEFAULT_STORE_LOG=${logdir}/store.log \
+ DEFAULT_PID_FILE=${localstatedir}/run/squid.pid \
+ DEFAULT_SWAP_DIR=${localstatedir}/spool/squid \
+ "
+
+INITSCRIPT_NAME = "squid"
+
do_configure_append() {
sed -i -e 's|./cf_gen |${STAGING_BINDIR_NATIVE}/cf_gen |g' src/Makefile
}
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/squid.init ${D}${sysconfdir}/init.d/squid
+}
+
# this packages the languages better and saves some space, installs
# English as errors default and the others in locale package