summaryrefslogtreecommitdiff
path: root/packages/squashfs-tools/files/Makefile-2.2.patch
diff options
context:
space:
mode:
authorJonathan McDowell <noodles@earth.li>2005-11-06 15:55:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-06 15:55:02 +0000
commit2facb231816e94ade58ec133c4612acb1979c261 (patch)
treec65a4e15d052cc24443b45d4876ef8b79bde9406 /packages/squashfs-tools/files/Makefile-2.2.patch
parent413b4d7adf6863ad55bbb43cd714cf3c60c7c3e2 (diff)
squashfs-tools: Add squashfs-tools 2.2.
Diffstat (limited to 'packages/squashfs-tools/files/Makefile-2.2.patch')
-rw-r--r--packages/squashfs-tools/files/Makefile-2.2.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/squashfs-tools/files/Makefile-2.2.patch b/packages/squashfs-tools/files/Makefile-2.2.patch
new file mode 100644
index 0000000000..7a16129bbc
--- /dev/null
+++ b/packages/squashfs-tools/files/Makefile-2.2.patch
@@ -0,0 +1,21 @@
+--- squashfs-tools/Makefile.orig 2005-10-26 18:15:43.641623000 +0100
++++ squashfs-tools/Makefile 2005-10-26 18:21:29.747253250 +0100
+@@ -1,12 +1,17 @@
+ INCLUDEDIR = .
++CFLAGS_R = -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
++LIBS = -lz
+
+ CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -g
+
+ mksquashfs: mksquashfs.o read_fs.o sort.o
+- $(CC) mksquashfs.o read_fs.o sort.o -lz -o $@
++ $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o -lz -o $@
+
+ mksquashfs.o: mksquashfs.c mksquashfs.h
++ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o mksquashfs.o mksquashfs.c
+
+ read_fs.o: read_fs.c read_fs.h
++ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o read_fs.o read_fs.c
+
+ sort.o: sort.c
++ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o sort.o sort.c