summaryrefslogtreecommitdiff
path: root/packages/sqlite/sqlite3-3.3.13/ldflags.patch
diff options
context:
space:
mode:
authorErik Hovland <erik@hovland.org>2007-02-21 18:08:45 +0000
committerErik Hovland <erik@hovland.org>2007-02-21 18:08:45 +0000
commit4afef870a4cacf726ff356a1816bf65809b74a9a (patch)
tree8755c46f462d958c22f07f41f78ddd3864a2e0a9 /packages/sqlite/sqlite3-3.3.13/ldflags.patch
parent1d0de2512caa025d306b937a414b8edf10ab2b23 (diff)
sqlite3 3.3.13: Point release
* Sqlite has released a new point release for Sqlite3. It fixes one bug when using ORDER BY. * The patches for 3.3.12 have been rebased for 3.3.13 and are included in the 3.3.13 directory. * The 3.3.13 bb file is an almost exact copy of the 3.3.12 bb.
Diffstat (limited to 'packages/sqlite/sqlite3-3.3.13/ldflags.patch')
-rw-r--r--packages/sqlite/sqlite3-3.3.13/ldflags.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/packages/sqlite/sqlite3-3.3.13/ldflags.patch b/packages/sqlite/sqlite3-3.3.13/ldflags.patch
new file mode 100644
index 0000000000..fb78ab9d87
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.3.13/ldflags.patch
@@ -0,0 +1,70 @@
+Index: sqlite-3.3.9/Makefile.in
+===================================================================
+--- sqlite-3.3.9.orig/Makefile.in 2007-01-08 19:37:52.000000000 +0100
++++ sqlite-3.3.9/Makefile.in 2007-01-08 19:41:54.000000000 +0100
+@@ -31,6 +31,10 @@
+ #
+ TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
+
++# OE overrides
++#
++TARGET_LFLAGS = @TARGET_LFLAGS@
++
+ # Define -DNDEBUG to compile without debugging (i.e., for production usage)
+ # Omitting the define will cause extra debugging code to be inserted and
+ # includes extra comments when "EXPLAIN stmt" is used.
+@@ -276,17 +280,17 @@
+ | $(NAWK) '{print $$5,$$6}' >last_change
+
+ libsqlite3.la: $(LIBOBJ)
+- $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
++ $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
+ ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
+
+ libtclsqlite3.la: tclsqlite.lo libsqlite3.la
+ $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
+- $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
++ $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
+ -rpath $(libdir)/sqlite \
+ -version-info "8:6:8"
+
+ sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
+- $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
++ $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
+ -o $@ $(TOP)/src/shell.c libsqlite3.la \
+ $(LIBREADLINE) $(TLIBS)
+
+@@ -474,13 +478,13 @@
+
+ tclsqlite3: tclsqlite-shell.lo libsqlite3.la
+ $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
+- libsqlite3.la $(LIBTCL)
++ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+
+ testfixture$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC)
+ $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 -DSQLITE_CRASH_TEST=1 \
+ -DSQLITE_NO_SYNC=1 $(TEMP_STORE) \
+ -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
+- libsqlite3.la $(LIBTCL)
++ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+
+
+ fulltest: testfixture$(TEXE) sqlite3$(TEXE)
+@@ -490,7 +494,7 @@
+ ./testfixture $(TOP)/test/quick.test
+
+ sqlite3_analyzer$(TEXE): $(TOP)/src/tclsqlite.c libtclsqlite3.la \
+- $(TESTSRC) $(TOP)/tool/spaceanal.tcl
++ $(TARGET_LFLAGS) $(TESTSRC) $(TOP)/tool/spaceanal.tcl
+ sed \
+ -e '/^#/d' \
+ -e 's,\\,\\\\,g' \
+@@ -500,7 +504,7 @@
+ $(TOP)/tool/spaceanal.tcl >spaceanal_tcl.h
+ $(LTLINK) -DTCLSH=2 -DSQLITE_TEST=1 $(TEMP_STORE)\
+ -o sqlite3_analyzer$(EXE) $(TESTSRC) $(TOP)/src/tclsqlite.c \
+- libtclsqlite3.la $(LIBTCL)
++ libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+
+ # Rules used to build documentation
+ #